Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in phpMyAdmin
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in phpMyAdmin
ID: 200803-15
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 9. März 2008, 21:51
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1149
Applikationen: phpMyAdmin

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200803-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: phpMyAdmin: SQL injection vulnerability
Date: March 09, 2008
Bugs: #212000
ID: 200803-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A SQL injection vulnerability has been discovered in phpMyAdmin.

Background
==========

phpMyAdmin is a free web-based database administration tool.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/phpmyadmin < 2.11.5 >= 2.11.5

Description
===========

Richard Cunningham reported that phpMyAdmin uses the $_REQUEST variable
of $_GET and $_POST as a source for its parameters.

Impact
======

An attacker could entice a user to visit a malicious web application
that sets an "sql_query" cookie and is hosted on the same domain as
phpMyAdmin, and thereby conduct SQL injection attacks with the
privileges of the user authenticating in phpMyAdmin afterwards.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All phpMyAdmin users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/phpmyadmin-2.11.5"

References
==========

[ 1 ] CVE-2008-1149
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1149

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200803-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFH1FpKuhJ+ozIKI5gRAv/nAJ9WtP7uBXB1BLbfg6tARcS98/vvqgCZASRk
UUDajtMwq5izrnY6UOCoJcg=
=2ti+
-----END PGP SIGNATURE-----
--
gentoo-announce@lists.gentoo.org mailing list
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung