Login
Newsletter
Werbung

Sicherheit: Mangelnde Eingabeprüfung in PHP
Aktuelle Meldungen Distributionen
Name: Mangelnde Eingabeprüfung in PHP
ID: 200804-19
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Fr, 18. April 2008, 01:46
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1734
Applikationen: PHP

Originalnachricht

--nextPart1614374.gIcCkGu2gk
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200804-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PHP Toolkit: Data disclosure and Denial of Service
Date: April 17, 2008
Bugs: #209535
ID: 200804-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PHP Toolkit does not quote parameters, allowing for PHP source code
disclosure on Apache, and a Denial of Service.

Background
==========

PHP Toolkit is a utility to manage parallel installations of PHP within
Gentoo. It is executed by the PHP ebuilds at setup.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/php-toolkit < 1.0.1 >= 1.0.1

Description
===========

Toni Arnold, David Sveningsson, Michal Bartoszkiewicz, and Joseph
reported that php-select does not quote parameters passed to the "tr"
command, which could convert the "-D PHP5" argument in the
"APACHE2_OPTS" setting in the file /etc/conf.d/apache2 to lower case.

Impact
======

An attacker could entice a system administrator to run "emerge php" or
call "php-select -t apache2 php5" directly in a directory containing a
lower case single-character named file, which would prevent Apache from
loading mod_php and thereby disclose PHP source code and cause a Denial
of Service.

Workaround
==========

Do not run "emerge" or "php-select" from a working directory
which
contains a lower case single-character named file.

Resolution
==========

All PHP Toolkit users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=app-admin/php-toolkit-1.0.1"

References
==========

[ 1 ] CVE-2008-1734
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1734

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200804-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart1614374.gIcCkGu2gk
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iD8DBQBIB97IyZx3L/ph1soRAiJnAJ9lZi9sbp86TwtISVF1kZnytIqUYQCgxrqv
uKqSAedx8PwdXHZAd2x5QhA=
=Bj9x
-----END PGP SIGNATURE-----

--nextPart1614374.gIcCkGu2gk--
--
gentoo-announce@lists.gentoo.org mailing list
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung