Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in gstreamer-plugins-good
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in gstreamer-plugins-good
ID: MDVSA-2008:092
Distribution: Mandriva
Plattformen: Mandriva 2008.0, Mandriva 2008.1
Datum: Di, 29. April 2008, 23:31
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1686
http://www.ocert.org/advisories/ocert-2008-004.html
Applikationen: GStreamer

Originalnachricht

This is a multi-part message in MIME format...

------------=_1209504705-11275-3482


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2008:092
http://www.mandriva.com/security/
_______________________________________________________________________

Package : gstreamer-plugins-good
Date : April 29, 2008
Affected: 2008.0, 2008.1
_______________________________________________________________________

Problem Description:

A vulnerability in the Speex library was found where it did not
properly validate input values read from the Speex files headers.
An attacker could create a malicious Speex file that would crash an
application or potentially allow the execution of arbitrary code
with the privileges of the application calling the Speex library
(CVE-2008-1686).

The speex plugin in the gstreamer-plugins-good package is similarly
affected by this issue.

The updated packages have been patched to correct this issue.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1686
http://www.ocert.org/advisories/ocert-2008-004.html
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2008.0:
ed3a050e02cd4931111999597ea5a82e
2008.0/i586/gstreamer0.10-aalib-0.10.6-3.1mdv2008.0.i586.rpm
1bea970aa242035b23f8c9d4fbe679f8
2008.0/i586/gstreamer0.10-caca-0.10.6-3.1mdv2008.0.i586.rpm
88f07a2b3941132b50eb0f83806fb2fe
2008.0/i586/gstreamer0.10-dv-0.10.6-3.1mdv2008.0.i586.rpm
ff51915eb83580f67344664b4869b85c
2008.0/i586/gstreamer0.10-esound-0.10.6-3.1mdv2008.0.i586.rpm
c65b3ecb7496c4be16da27364844a5b4
2008.0/i586/gstreamer0.10-flac-0.10.6-3.1mdv2008.0.i586.rpm
90bf9f4401b964d37c0042ef43b5cb3e
2008.0/i586/gstreamer0.10-plugins-good-0.10.6-3.1mdv2008.0.i586.rpm
11d9705da24e698e71d8ec35975fda2f
2008.0/i586/gstreamer0.10-raw1394-0.10.6-3.1mdv2008.0.i586.rpm
2fba4b37380d4084d2a600237ae69f53
2008.0/i586/gstreamer0.10-speex-0.10.6-3.1mdv2008.0.i586.rpm
7b773b42b2c15dc2358c1094bdb17e31
2008.0/i586/gstreamer0.10-wavpack-0.10.6-3.1mdv2008.0.i586.rpm
be855c4fc17a6ef63cfb2546ebfb7eeb
2008.0/SRPMS/gstreamer0.10-plugins-good-0.10.6-3.1mdv2008.0.src.rpm

Mandriva Linux 2008.0/X86_64:
9b5bea636605af0749f8c5ac238b6ccd
2008.0/x86_64/gstreamer0.10-aalib-0.10.6-3.1mdv2008.0.x86_64.rpm
86698a7ca2b3f6de3ad172ad4e52610b
2008.0/x86_64/gstreamer0.10-caca-0.10.6-3.1mdv2008.0.x86_64.rpm
65638c588ff190f30839ef17cfc1775e
2008.0/x86_64/gstreamer0.10-dv-0.10.6-3.1mdv2008.0.x86_64.rpm
f6541018cc3f6aebcde8096e96479fcb
2008.0/x86_64/gstreamer0.10-esound-0.10.6-3.1mdv2008.0.x86_64.rpm
ad23357c877a05e689c9a471db362bd3
2008.0/x86_64/gstreamer0.10-flac-0.10.6-3.1mdv2008.0.x86_64.rpm
1ba30996ecce44c97c0ee23490989c6f
2008.0/x86_64/gstreamer0.10-plugins-good-0.10.6-3.1mdv2008.0.x86_64.rpm
b26efd203758a66b86f142cefaeac8fb
2008.0/x86_64/gstreamer0.10-raw1394-0.10.6-3.1mdv2008.0.x86_64.rpm
9aa9f0e120b190451991d0aeef343c34
2008.0/x86_64/gstreamer0.10-speex-0.10.6-3.1mdv2008.0.x86_64.rpm
c6c4ed2f31fff82d17a7c3530335308f
2008.0/x86_64/gstreamer0.10-wavpack-0.10.6-3.1mdv2008.0.x86_64.rpm
be855c4fc17a6ef63cfb2546ebfb7eeb
2008.0/SRPMS/gstreamer0.10-plugins-good-0.10.6-3.1mdv2008.0.src.rpm

Mandriva Linux 2008.1:
b7494735de0d468aa49f0d4545e17cc4
2008.1/i586/gstreamer0.10-aalib-0.10.7-3.1mdv2008.1.i586.rpm
6e84dde5c04f47fdb640e1976f4ded73
2008.1/i586/gstreamer0.10-caca-0.10.7-3.1mdv2008.1.i586.rpm
36b5d2542e8def9f710362a5a25bbf0b
2008.1/i586/gstreamer0.10-dv-0.10.7-3.1mdv2008.1.i586.rpm
6e1362779e4272436197d5bfc05bbbca
2008.1/i586/gstreamer0.10-esound-0.10.7-3.1mdv2008.1.i586.rpm
6c152867628f39c4b0e97168efb65faa
2008.1/i586/gstreamer0.10-flac-0.10.7-3.1mdv2008.1.i586.rpm
60c3422081cbc994f958f13a11f8e7d6
2008.1/i586/gstreamer0.10-plugins-good-0.10.7-3.1mdv2008.1.i586.rpm
d28097a2efb5ed2be23c103dcadfd05d
2008.1/i586/gstreamer0.10-raw1394-0.10.7-3.1mdv2008.1.i586.rpm
32a01bbbda46f269f70404ad65cb9db1
2008.1/i586/gstreamer0.10-speex-0.10.7-3.1mdv2008.1.i586.rpm
5ed0d6100ac0bf3aabaab7a3f48c82f9
2008.1/i586/gstreamer0.10-wavpack-0.10.7-3.1mdv2008.1.i586.rpm
df7434ce633a1e6e0f19d4027aa78a72
2008.1/SRPMS/gstreamer0.10-plugins-good-0.10.7-3.1mdv2008.1.src.rpm

Mandriva Linux 2008.1/X86_64:
9ba07cb4a4f098260a430bddcd8fa6c8
2008.1/x86_64/gstreamer0.10-aalib-0.10.7-3.1mdv2008.1.x86_64.rpm
2f1f5879cd92531baf08622d229bdf2d
2008.1/x86_64/gstreamer0.10-caca-0.10.7-3.1mdv2008.1.x86_64.rpm
5e86a24131c0b2074059b64e08f565df
2008.1/x86_64/gstreamer0.10-dv-0.10.7-3.1mdv2008.1.x86_64.rpm
e3a252410b2d385907eb1075894eefe9
2008.1/x86_64/gstreamer0.10-esound-0.10.7-3.1mdv2008.1.x86_64.rpm
ec85d1c5e4fc3d5675648cfc24481566
2008.1/x86_64/gstreamer0.10-flac-0.10.7-3.1mdv2008.1.x86_64.rpm
06810f43df4aa1bbbc8884179b1e10aa
2008.1/x86_64/gstreamer0.10-plugins-good-0.10.7-3.1mdv2008.1.x86_64.rpm
315bc267569bd6202f954faf634744c6
2008.1/x86_64/gstreamer0.10-raw1394-0.10.7-3.1mdv2008.1.x86_64.rpm
0385bde5219b113cd40675aaa0d901b5
2008.1/x86_64/gstreamer0.10-speex-0.10.7-3.1mdv2008.1.x86_64.rpm
69b0130dacaee4796a72e2ab12930349
2008.1/x86_64/gstreamer0.10-wavpack-0.10.7-3.1mdv2008.1.x86_64.rpm
df7434ce633a1e6e0f19d4027aa78a72
2008.1/SRPMS/gstreamer0.10-plugins-good-0.10.7-3.1mdv2008.1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFIF2iWmqjQ0CJFipgRAj94AKCSIFyoU3aE0ZJQxOejrNeMKy1KoACeI9tB
as9OcpK75RuNLUBIsp8pmPI=
=0y4Y
-----END PGP SIGNATURE-----


------------=_1209504705-11275-3482
Content-Type: text/plain; name="message-footer.txt"
Content-Disposition: inline; filename="message-footer.txt"
Content-Transfer-Encoding: 8bit

To unsubscribe, send a email to sympa@mandrivalinux.org
with this subject : unsubscribe security-announce
_______________________________________________________
Want to buy your Pack or Services from Mandriva?
Go to http://www.mandrivastore.com
Join the Club : http://www.mandrivaclub.com
_______________________________________________________

------------=_1209504705-11275-3482--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung