Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in BitlBee
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in BitlBee
ID: 200809-14
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Di, 23. September 2008, 23:38
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3920
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3969
Applikationen: BitlBee

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig06DEA99D6089427BF3285E94
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200809-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/=

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: BitlBee: Security bypass
Date: September 23, 2008
Bugs: #236160
ID: 200809-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Bitlbee may allow to bypass security
restrictions and hijack accounts.

Background
==========

BitlBee is an IRC to IM gateway that support multiple IM protocols.

Affected packages
=================

-------------------------------------------------------------------=

Package / Vulnerable / Unaffected
-------------------------------------------------------------------=

1 net-im/bitlbee < 1.2.3 >=3D
1.2.=
3

Description
===========

Multiple unspecified vulnerabilities were reported, including a NULL
pointer dereference.

Impact
======

A remote attacker could exploit these vulnerabilities to overwrite
existing IM accounts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All BitlBee users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=3Dnet-im/bitlbee-1.2.3"

References
==========

[ 1 ] CVE-2008-3920
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-3920
[ 2 ] CVE-2008-3969
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-3969

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200809-14.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




--------------enig06DEA99D6089427BF3285E94
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkjZYK8ACgkQuhJ+ozIKI5h2PwCeOeKtHDNS/8SWHUgWuJT3lMur
AFgAniOS684Jg2LtoXjEWka81jC7vNfK
=kxC2
-----END PGP SIGNATURE-----

--------------enig06DEA99D6089427BF3285E94--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung