Login
Newsletter
Werbung

Sicherheit: Pufferüberläufe in Git
Aktuelle Meldungen Distributionen
Name: Pufferüberläufe in Git
ID: 200809-16
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Do, 25. September 2008, 23:14
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3546
Applikationen: Git

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig1C88913EF1F699694BC5F700
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200809-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/=

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Git: User-assisted execution of arbitrary code
Date: September 25, 2008
Bugs: #234075
ID: 200809-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple buffer overflow vulnerabilities have been discovered in Git.

Background
==========

Git is a distributed version control system.

Affected packages
=================

-------------------------------------------------------------------=

Package / Vulnerable / Unaffected
-------------------------------------------------------------------=

1 dev-util/git < 1.5.6.4 >=3D
1.5.6.=
4

Description
===========

Multiple boundary errors in the functions diff_addremove() and
diff_change() when processing overly long repository path names were
reported.

Impact
======

A remote attacker could entice a user to run commands like "git-diff"
or "git-grep" on a specially crafted repository, possibly resulting in
the remote execution of arbitrary code with the privileges of the user
running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Git users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=3Ddev-util/git-1.5.6.4"

References
==========

[ 1 ] CVE-2008-3546
http://cve.mitre.org/cgi-bin/cvename.cgi?name=3DCVE-2008-3546

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200809-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




--------------enig1C88913EF1F699694BC5F700
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkjb/hUACgkQuhJ+ozIKI5j4jACdGoycfvIXPRW8TIe1Q6dW7Jxn
zOgAoJ826UiTYnKEk4xIswQm1kqk+8ZX
=5o8F
-----END PGP SIGNATURE-----

--------------enig1C88913EF1F699694BC5F700--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung