Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in Smarty
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in Smarty
ID: USN-791-3
Distribution: Ubuntu
Plattformen: Ubuntu 9.04
Datum: Mi, 24. Juni 2009, 22:07
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1669
Applikationen: Smarty PHP template engine

Originalnachricht


--===============2013998146280330298==
Content-Type: multipart/signed; micalg=pgp-sha1;
protocol="application/pgp-signature";
boundary="sHrvAb52M6C8blB9"
Content-Disposition: inline


--sHrvAb52M6C8blB9
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

===========================================================
Ubuntu Security Notice USN-791-3 June 24, 2009
smarty vulnerability
CVE-2009-1669
===========================================================

A security issue affects the following Ubuntu releases:

Ubuntu 9.04

This advisory also applies to the corresponding versions of
Kubuntu, Edubuntu, and Xubuntu.

The problem can be corrected by upgrading your system to the
following package versions:

Ubuntu 9.04:
smarty 2.6.22-1ubuntu1.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

Details follow:

It was discovered that Smarty did not correctly filter certain math
inputs. A remote attacker using Smarty via a web service could exploit
this to execute subsets of shell commands as the web server user.


Updated packages for Ubuntu 9.04:

Source archives:

smarty_2.6.22-1ubuntu1.1.diff.gz
Size/MD5: 5384 cddf82ac12a8bf55573d7382cbbb3609
smarty_2.6.22-1ubuntu1.1.dsc
Size/MD5: 1220 b96705a4b32e7e7e0965a71986f908b8
smarty_2.6.22.orig.tar.gz
Size/MD5: 158529 a6e1d94453104c42374901da5139744c

Architecture independent packages:

smarty_2.6.22-1ubuntu1.1_all.deb
Size/MD5: 204018 7ed9dc3ba0843ff6b2acf57f94ee31c3


--sHrvAb52M6C8blB9
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkpChkQACgkQH/9LqRcGPm3LvQCeL2uMcRVfneTGUTp/RX7hn0g7
lT4AoJD2vh0fMMqeW2xrVSPP9o72DoLn
=SDk+
-----END PGP SIGNATURE-----

--sHrvAb52M6C8blB9--


--===============2013998146280330298==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============2013998146280330298==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung