Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Squid erzeugt hohe cpu-Last..

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Max
Gast





BeitragVerfasst am: 06. Aug 2001 16:36   Titel: Squid erzeugt hohe cpu-Last..

habe hier squid Transparent laufen.
Leider zeigt top :
PID USER PRI NI SIZE RSS SHARE STAT LIB %CPU %MEM TIME COMMAND
18842 proxy 14 0 5424 5420 1148 R 0 98.4 8.5 1:39 squid


Dabei ist das Ding im Leerlauf.
Im Usenet scheine ich nicht der einzige zu sein
Dieses Problem scheint mehrere Leute zu haben.
Auch scheint ein Update auf 2.4 Stable nicht zu helfen.
Leider konnte ich keine Lösung dazu finden.
Hat jemand noch eine Idee??
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 07. Aug 2001 13:17   Titel: Re: Squid erzeugt hohe cpu-Last..

Hi,

ich hatte das auch schon. Leider weiß ich nicht genau, was die Ursache dafür ist.
Stoppe Squid mal und stelle sicher, daß wirklich alle Squid-Prozesse weg sind (ps ax|grep sq). Dann starte ihn neu.

Wenn das nichts hilft, warte mal ein Weilchen. Vielleicht arbeitet er nur den Cache durch und wird irgendwann fertig damit.
Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Max
Gast





BeitragVerfasst am: 07. Aug 2001 14:56   Titel: Re: Squid erzeugt hohe cpu-Last..

Seltsam, habe ich jetzt mal ausprobiert.
Wenn squid startet ist erstmal alles in Ordnung.
Sobald er aber die erste Anfrage durchschickt knallt er voll auf und kommt auch nicht wieder runter.
Egal wie lange ich warte.
NAch jeden Squid-Neustart dasselbe.
Bei squid-cache.org habe ich nur folgenden Hinweis gefunden:
>11.46 Squid uses 100% CPU
>
>There may be many causes for this.
>
>Andrew Doroshenko reports that removing /dev/null, or mounting a filesystem with the nodev option, can cause Squid to >use 100% of CPU. His suggested solution is to ``touch /dev/null.''
>
Na ja, hilft nicht wirklich :-(
Mein /dev/null rennt wunderbar...

Ich habe das Gefühl das hängt mit dem transparenten Betrieb zusammen, mal austesten.
Danke erstmal für deine Tipps, wenn ich noch was rausfinde werde ich es hier posten...
Gruss Max
 

Max
Gast





BeitragVerfasst am: 08. Aug 2001 11:34   Titel: Re: Squid erzeugt hohe cpu-Last..

für den der es wissen will:

Problem abgehakt:

icp_port 0
htcp_port 0

Ich habe squid transparent betrieben. Alle Anfragen schickte er an einen anderen Proxie
(Trendmicro Viruswall, der kann nicht transparent...)
Anscheinden wusste der Proxie von Trendmicro nichts mit ICP und HTCP Anfragen anzufangen und squid war entsprechend konfiguriert (never_direct allow all) um ausschließlich jeden Traffic an die Viruswall zu senden.
Jedenfalls funktioniert er jetzt tadellos!
:-)
Gruss Max
 

MartinHeuser
Gast





BeitragVerfasst am: 09. Aug 2001 22:21   Titel: Re: Squid erzeugt hohe cpu-Last..

Zur Not einfach Nice starten :)

Gruß
 

Max
Gast





BeitragVerfasst am: 10. Aug 2001 8:33   Titel: Re: Squid erzeugt hohe cpu-Last..

hatte gelogen
Es lief noch nicht tadellos...es lief nur besser.
M.E. ist Squid 2.2 stable nicht stable.
Ok, ich nutze seine Features voll aus, (parent cache, http-accel, acl usw)
aber das sollte er schließlich abkönnen.
Wenn man im Usenet sucht findet man viele Leute die ähnliche Probleme haben.
Aber nirgendwo habe ich eine Lösung gefunden. Anscheinend bringt Squid 2.4 auch keine Anhilfe.
Leider ist Squid was die Feature angeht die einzige Alternative.
Oder kennt noch jemand einen Proxy für Linux der transparent kann und seine Anfrage an andere Caches weiterreicht???

Mit viel Try & Error läuft er jetzt bei mir recht stabil, aber alles sehr ärgerlich.
Squid ist ok wenn er einfach cacht und sonst nix.
Max
 

SR-Software
Gast





BeitragVerfasst am: 11. Okt 2013 18:49   Titel: Hohe Squid CPU-Last

(Das Problem tritt auch mit Squid 3.1 von Debian 7_64Bit auf....)

eventuell hilft:
check_hostnames off

vorher CPU-Last bei Zugriff ~75-85%
jetzt ca. 7-24%

eventuell vor Server Neustart den Cache neu initialisieren.....
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy