Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
hpdj 5550 und Slackware 10.0

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Hardware
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
slacknewbie
Gast





BeitragVerfasst am: 13. Okt 2004 20:12   Titel: hpdj 5550 und Slackware 10.0

Hallo Zusammen!

Ich habe Probleme meinen HP DJ 5550 am Parallelport mit Slackware 10.0 über CUPS zum Laufen zu bringen.

Ich habe schon in der /etc/rc.d/rc.modules den PC Parallelport Support und den Parallel Printer Support schon auskommentiert; auf dem CUPS-Web-Fronted wird der lp0 auch wunderbar angezeitgt.

Aber beim Drucken einer Testseite kommt der client-error-not-possible Fehler.

Ich habe folgende Pakete, die meines Erachtens zum Drucken notwendig sind installiert:
libjpeg,libpng,zlib,gimp-print,hpijs,cups,a2ps,apsfilter,espgs

Oder muss ich was an den Rechten von /dev/lo0 ändern?

Vielen Dank im Voraus
 

elwood67



Anmeldungsdatum: 19.05.2004
Beiträge: 232
Wohnort: Nürnberg

BeitragVerfasst am: 13. Okt 2004 20:34   Titel: Verstehe ich was falsch?

Wenn Du einen Drucker am Parallelport hängen hast, warum kommentierst Du dann den Parallelport aus?
Ich hatte letztens auch einen HP über einen besonderen Treiber zum Laufen gebracht, der bei jedem Start ein Image nach /dev/lp0 schickte, dann lief er.
Musst Du mal suchen im Web oder hier.

Aber die Parallelportunterstützung zu deaktivieren, ob das der richtieg Weg ist???
_________________
Gruß Jürgen
_______________________
Rechner: P4 mit Suse 9.2
_______________________
Und versammeln unsere eigene Armee, um diese Massenvernichtungswaffe zu entschärfen, die wir heute noch unseren Präsidenten nennen...
 
Benutzer-Profile anzeigen Private Nachricht senden

kanonenfutter



Anmeldungsdatum: 10.09.2004
Beiträge: 266

BeitragVerfasst am: 13. Okt 2004 20:44   Titel:

nach der slack-installation kriegt root ja ein paar mails. in einer heisst es:
Zitat:
If you've done a full installation and you want to use CUPS, you might want to reinstall the CUPS package to set various links (like /usr/bin/lpr) to point to the CUPS versions -- these locations are shared between LPRng and CUPS, and all of the links will be pointed to the programs from whichever package (cups or lprng) was installed last. Normally this will be LPRng.
die frage ist also: hast du bei der installation lprng abgewählt? falls nein, dann musst du das cups-paket nochmal installieren. damit werden die lprng-links wieder überschrieben.
_________________
"Email und Internet haben gemeinsam, dass sie beide in HTML geschrieben sind" (Peter Huth, TV-Computerexperte). Zitiert nach http://www.antihuth.de/
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

elwood67



Anmeldungsdatum: 19.05.2004
Beiträge: 232
Wohnort: Nürnberg

BeitragVerfasst am: 13. Okt 2004 21:45   Titel: ?!

Zitat:

BeitragVerfasst am: 13. Okt 2004 21:44 Titel:
nach der slack-installation kriegt root ja ein paar mails. in einer heisst es:
Zitat:
If you've done a full installation and you want to use CUPS, you might want to reinstall the CUPS package to set various links (like /usr/bin/lpr) to point to the CUPS versions -- these locations are shared between LPRng and CUPS, and all of the links will be pointed to the programs from whichever package (cups or lprng) was installed last. Normally this will be LPRng.
die frage ist also: hast du bei der installation lprng abgewählt? falls nein, dann musst du das cups-paket nochmal installieren. damit werden die lprng-links wieder überschrieben.


@kanonenfutter
Respekt. Da wäre ich nicht drauf gekommen, aber ich fahre auch kein slack.
Das Problem ist aber, dass die meisten User über KDE/Gnome ins System gehen und da siehst Du von den Mail an root erstmal nichts.
_________________
Gruß Jürgen
_______________________
Rechner: P4 mit Suse 9.2
_______________________
Und versammeln unsere eigene Armee, um diese Massenvernichtungswaffe zu entschärfen, die wir heute noch unseren Präsidenten nennen...
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 13. Okt 2004 22:37   Titel:

@elwood67

Das ist ja das "geile" an Slacki. Brett vorn Kopp und
gucken wie man klar kommt.
Kaffee- Kippen- Distri Wink
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

slacknewbie
Gast





BeitragVerfasst am: 16. Okt 2004 19:43   Titel:

@elwood67:
Sorry habe mich verschrieben, ich wollte natürlich schreiben, dass ich die Kommentarrauten entfernt habe Wink

@kanonenfutter:
Das nochmalige Installieren half leider immer noch nicht Sad

@alle

mir ist im CUPS-Fronted, bei der Angabe des Druckeranschlusses übrigens aufgefallen, dass es folgende Anschlüsse zur Auswahl gab:
Parallel Port #1 CANON
Parallel Port #1 EPSON
Parallel Port #1 hp deskjet 5550

Hat es vielleicht damit was zu tun?
 

tom servo



Anmeldungsdatum: 01.06.2004
Beiträge: 225

BeitragVerfasst am: 17. Okt 2004 10:44   Titel:

@elwood67
Zitat:
Das Problem ist aber, dass die meisten User über KDE/Gnome ins System gehen und da siehst Du von den Mail an root erstmal nichts.

slackware startet immer ohne X ...
und wenn ich mich richtig erinnere, musst man den "normalen" user erst per Hand hinzufügen ....
zumindest kann ich mich sehr gut an die "You have a mail" Meldung erinnern,
aber anschauen muss man sie schon selbst ...Very Happy


Zuletzt bearbeitet von tom servo am 17. Okt 2004 12:59, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 17. Okt 2004 12:56   Titel:

>mir ist im CUPS-Fronted, bei der Angabe des Druckeranschlusses übrigens >aufgefallen, dass es folgende Anschlüsse zur Auswahl gab:
>Parallel Port #1 CANON
>Parallel Port #1 EPSON
>Parallel Port #1 hp deskjet 5550
>Hat es vielleicht damit was zu tun?

Da du einen hp deskjet 5550 hast...
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

slacknewbie
Gast





BeitragVerfasst am: 31. Okt 2004 10:41   Titel:

Hallo Zusammen!

Hatte jetzt mal wieder Zeit mich mit o.g. Problem zu befassen.

Ich habe euch mal die /var/log/cups/error_log angehängt, vielleicht könnt ihr daraus eine Ursache entnehmen.

Danke im Voraus!

I [30/Oct/2004:21:08:02 +0200] Listening to 0:631
I [30/Oct/2004:21:08:02 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [30/Oct/2004:21:08:02 +0200] Configured for up to 100 clients.
I [30/Oct/2004:21:08:02 +0200] Allowing up to 100 client connections per host.
I [30/Oct/2004:21:08:02 +0200] Full reload is required.
I [30/Oct/2004:21:08:10 +0200] LoadPPDs: Wrote "/etc/cups/ppds.dat", 523 PPDs...
I [30/Oct/2004:21:08:10 +0200] Full reload complete.
I [30/Oct/2004:21:13:42 +0200] Scheduler shutting down normally.
I [30/Oct/2004:21:27:33 +0200] Listening to 0:631
I [30/Oct/2004:21:27:33 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [30/Oct/2004:21:27:33 +0200] Configured for up to 100 clients.
I [30/Oct/2004:21:27:33 +0200] Allowing up to 100 client connections per host.
I [30/Oct/2004:21:27:33 +0200] Full reload is required.
I [30/Oct/2004:21:27:34 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 523 PPDs...
I [30/Oct/2004:21:27:34 +0200] LoadPPDs: No new or changed PPDs...
I [30/Oct/2004:21:27:34 +0200] Full reload complete.
I [30/Oct/2004:21:32:19 +0200] Scheduler shutting down normally.
I [30/Oct/2004:21:34:14 +0200] Listening to 0:631
I [30/Oct/2004:21:34:14 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [30/Oct/2004:21:34:14 +0200] Configured for up to 100 clients.
I [30/Oct/2004:21:34:14 +0200] Allowing up to 100 client connections per host.
I [30/Oct/2004:21:34:14 +0200] Full reload is required.
I [30/Oct/2004:21:34:14 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 523 PPDs...
I [30/Oct/2004:21:34:15 +0200] LoadPPDs: No new or changed PPDs...
I [30/Oct/2004:21:34:15 +0200] Full reload complete.
I [30/Oct/2004:21:35:57 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=583)
I [30/Oct/2004:21:36:05 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=584)
I [30/Oct/2004:21:36:19 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=589)
I [30/Oct/2004:21:36:26 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=590)
I [30/Oct/2004:21:36:30 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=591)
I [30/Oct/2004:21:36:39 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=592)
I [30/Oct/2004:21:36:39 +0200] Setting hpdj5550 device-uri to "parallel:/dev/lp0" (was "file:/dev/null".)
I [30/Oct/2004:21:36:39 +0200] Setting hpdj5550 printer-is-accepting-jobs to 1 (was 0.)
I [30/Oct/2004:21:36:39 +0200] Setting hpdj5550 printer-state to 3 (was 5.)
I [30/Oct/2004:21:36:39 +0200] Saving printers.conf...
I [30/Oct/2004:21:36:39 +0200] New printer 'hpdj5550' added by 'root'.
I [30/Oct/2004:21:36:41 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=593)
I [30/Oct/2004:21:36:44 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=594)
I [30/Oct/2004:21:36:44 +0200] Adding start banner page "none" to job 1.
I [30/Oct/2004:21:36:44 +0200] Adding end banner page "none" to job 1.
I [30/Oct/2004:21:36:44 +0200] Job 1 queued on 'hpdj5550' by 'root'.
I [30/Oct/2004:21:36:44 +0200] Started filter /usr/lib/cups/filter/pstops (PID 595) for job 1.
I [30/Oct/2004:21:36:44 +0200] Started filter /usr/lib/cups/filter/foomatic-rip (PID 596) for job 1.
I [30/Oct/2004:21:36:44 +0200] Started backend /usr/lib/cups/backend/parallel (PID 597) for job 1.
E [30/Oct/2004:21:36:44 +0200] PID 596 stopped with status 22!
I [30/Oct/2004:21:36:44 +0200] Hint: Try setting the LogLevel to "debug" to find out more.
I [30/Oct/2004:21:37:23 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=598)
I [30/Oct/2004:21:37:25 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=599)
I [30/Oct/2004:21:37:33 +0200] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=600)
E [30/Oct/2004:21:37:33 +0200] restart_job: job #1 cannot be restarted - no files!
I [30/Oct/2004:21:38:37 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=601)
I [30/Oct/2004:21:38:45 +0200] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=602)
I [30/Oct/2004:21:38:49 +0200] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=603)
 

kanonenfutter



Anmeldungsdatum: 10.09.2004
Beiträge: 266

BeitragVerfasst am: 31. Okt 2004 23:19   Titel:

vielleicht so?:
http://evan.mcnabbs.org/linux-oss/miscproblems.shtml:
Zitat:

/var/log/cups/error_log:

I [12/Dec/2003:19:53:26 -0700] Saving printers.conf...
I [12/Dec/2003:19:53:26 -0700] Printer 'hl1440-usb' started by 'root'.
I [12/Dec/2003:19:53:26 -0700] Started filter /usr/lib/cups/filter/pstops (PID 10909) for job 101.
E [12/Dec/2003:19:53:26 -0700] PID 10910 stopped with status 22!
I [12/Dec/2003:19:53:26 -0700] Hint: Try setting the LogLevel to "debug" to find out more.
I [12/Dec/2003:19:53:26 -0700] Started filter /usr/lib/cups/filter/foomatic-rip (PID -10910) for job 101.
I [12/Dec/2003:19:53:26 -0700] Started backend /usr/lib/cups/backend/usb (PID 10911) for job 101.
W [12/Dec/2003:19:53:26 -0700] [Job 101] Media tray empty!
I [12/Dec/2003:19:53:26 -0700] Saving printers.conf...

I needed to emerge (install) foomatic. This installed the foomatic-filters-3.0.0, foomatic-db-engine-3.0.0, foomatic-db-20030716, foomatic-3.0.0. I restarted cups and everything worked fine.

_________________
"Email und Internet haben gemeinsam, dass sie beide in HTML geschrieben sind" (Peter Huth, TV-Computerexperte). Zitiert nach http://www.antihuth.de/
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Hardware Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy