Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
wie stoppt man proftpd ?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
dany_fun
Gast





BeitragVerfasst am: 29. Jul 2005 23:41   Titel: wie stoppt man proftpd ?

hi all ...

habe hier einige probleme mit proftpd

hier mal mein config file

# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "ProFTPD Default Installation"
ServerType standalone
DefaultServer on

# Port 21 is the standard FTP port.
Port 2121

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 30

# Set the user and group under which the server will run.
User daniel
Group users

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
DefaultRoot ~

# Normally, we want files to be overwriteable.
AllowOverwrite on

# Bar use of SITE CHMOD by default
<Limit SITE_CHMOD>
DenyAll
</Limit>



also es hauen einige dinge nicht hin..

erstens: ich kann problemlos auf höhere ebenen zugfreiffen,obwohl eigentlich lock user in homedir. gesetzt wäre..

zweitens: mir kommt es komisch vor,dass er port 2121 im clienten sofort kennt .. also ich brauch nur ip eingeben,und der client kann sofort connecten.. normal geht das nur bei port 21,da nimmt der client automatisch an (Falls nix anderes angegeben ist) dass es sich um den handelt..

drittens.. ich weiss net wie man den server stoppen kann ..
mit kill PID gehts zwar temporär,aber sobald ich versuche auf den FTP zu connecten startet proftpd wieder neu,halt unter neuer PID ...

vielleicht kannma wer rat geben Smile

btw.. ubuntu 5 , proftpd 1.2.10
 

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 30. Jul 2005 8:34   Titel:

Hi

Du solltest den Server auch mit "killall proftpd" (oder wie immer das laufende Programm heißt) oder "/etc/init.d/proftpd stop" (oder wie immer das Init-Skript heißt) stoppen können.

Um heraus zu bekommen, auf welchem Port der Server wirklich läuft, würde ich einfach mal einen kleinen Portscan durch führen:

Code:
nmap -sT -p '21,2121' [ip]


Außerdem denke ich, dass das chrooten aus dem Grund nicht funktioniert, dass du als Benutzer daniel, group users gesetzt hast. Normalerweise gibt es einen richtigen ftp-user der dafür da ist. Vielleicht hat daniel keinen Zugriff auf die Home-Verzeichnisse anderer Nutzer.

Achso:
Zitat:

drittens.. ich weiss net wie man den server stoppen kann ..
mit kill PID gehts zwar temporär,aber sobald ich versuche auf den FTP zu connecten startet proftpd wieder neu,halt unter neuer PID ..


Das klingt extrem danach, dass dein FTP-Server vom inetd gestartet wird. Mit dem arbeite ich nicht, aber du solltest irgendwo unter /etc die Config dafür finden und außerdem gibt's im Netz sicher Dokumentation dafür.

Code:
It establishes a single server
# and a single anonymous login.


Falls du Probleme weitergehen: oftp ist auch ein sehr schicker kleiner anonymer FTP-Server.
 
Benutzer-Profile anzeigen Private Nachricht senden

dany_fun
Gast





BeitragVerfasst am: 30. Jul 2005 11:18   Titel:

das verwirrt mich ja Very Happy
unter /etc/init.d ist kein proftpd skript drinn ....
und er wär eigentlich auf standalone gestellt..

das nächste..
mit killall proftpd kill ich ihn solange bis er wieder ne anfrage bekommt Very Happy

mfg
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 30. Jul 2005 12:13   Titel:

Der inetd liest beim Start die Datei /etc/inetd.conf ein. Dabei werden Zeilen denen ein Kommentarzeichen (#) voransteht ignoriert, alle anderen verarbeitet. Auszug aus /etc/inetd.conf :

Code:

# These are standard services:
#
# Very Secure File Transfer Protocol (FTP) server.
#ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  vsftpd
#
# Professional File Transfer Protocol (FTP) server.
ftp     stream  tcp     nowait  root    /usr/sbin/tcpd  proftpd
#
# Telnet server:
#telnet stream  tcp     nowait  root    /usr/sbin/tcpd  in.telnetd


In diesem Beispiel werden vsftpd und telnet ignoriert, proftpd bei eintreffenden Anfragen gestartet. Um das abzustellen muss die betreffende Zeile auskommentiert (#) und inetd neu gestartet werden.

Zitat:

# Set the user and group under which the server will run.
User daniel
Group users


Ein Server sollte nicht unter uid und gid mit shellzugang laufen.

# Set the user and group that the server normally runs at.
User nobody
Group nogroup

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 30. Jul 2005 14:58   Titel:

> erstens: ich kann problemlos auf höhere ebenen zugfreiffen,obwohl eigentlich lock user in homedir. gesetzt wäre..
Dafür existiert die Option DefaultRoot ~

> zweitens: mir kommt es komisch vor,dass er port 2121 im clienten sofort kennt .. also ich brauch nur ip eingeben,
Gibst Du da zufällig ftp://ip-adresse an?

Zu drei hat klopskuchen schon etwas geschrieben

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

dany_fun
Gast





BeitragVerfasst am: 30. Jul 2005 17:18   Titel:

danke für eure antworten Smile
also die option mit dem einspeeren ins homeverzeichnis wär eigentlich gesetzt (Siehe mein config file oben)

ja .. ich gebe die adresse in dieser form ein.

ich hab allerdings rausgefunden,dass sich beim neustart des systems der port wirklich mitverändert hat .
 

dany_fun
Gast





BeitragVerfasst am: 30. Jul 2005 17:21   Titel:

das nächste sehr komische ist,dass in der /etc/inetd.conf kein eintrag von proFTPD existiert Very Happy

auch wär ja im configfile eigentlich standalone und nicht initd eingestellt (siehe mein config file oben...) ich steh echt vor einem net zu kleinen rätsel Smile

mgf dany
 

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 30. Jul 2005 19:14   Titel:

> das nächste sehr komische ist,dass in der /etc/inetd.conf kein eintrag von proFTPD existiert
Welchen Wrapper verwendest du? Läuft da zufällig ("der neuere") xinetd?

> auch wär ja im configfile eigentlich standalone und nicht initd eingestellt
Das kann mit der Eingabe von "pstree" geklärt werden. Ist proFTPD ein Fork des Wrappers?

In deinem ersten Posting fiel noch was auf:
> zweitens: mir kommt es komisch vor,dass er port 2121 im clienten sofort kennt
Wieviele ftp-Server laufen bei dir? Wink

MfG, Klopskuchen
_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

dany_fun
Gast





BeitragVerfasst am: 01. Aug 2005 12:41   Titel:

habs hinbekommen ..
also
stoppen des FTP'S : ftpshut

mit ftpshut -R kann man den FTP wieder starten (Dieses kommando muss ausgeführt werden,sonst kann der proftpd nicht mehr gestartet werden )


sonst klappts jetzt auch Smile

mfg dany
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy