Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Wine
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 20. Okt 2005 22:31   Titel: Wine

Hallo

Habe ein Problem mit Wine. Jedesmal wenn ich ein Programm starten will kommt die Fehlermeldung "Debugger gefunden" Und ich soll den dann entfernen....

Kann mir jemand sagen was Wine gegen einen Debugger hat (Wenn es ihn nicht braucht muss es ihn ja nicht aufrufen) und wie man das Problem eventuell beheben kann? (Den Debugger löschen kann ich nicht weil andere Programme nur mit debugger laufen...)

PS: Und kann mir jemand sagen um was für einen Debugger es hier geht (Habe gesehen dass es ne ganze Menge davon gibt)...

Gruss

Tinu
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 21. Okt 2005 8:17   Titel:

Kannst du bitte die genauen Fehlermeldungen posten? (Aus einer Shell starten.)
 
Benutzer-Profile anzeigen Private Nachricht senden

Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 21. Okt 2005 9:06   Titel:

linux:~ # wine /media/usb-ITETECHINC-USBTOIDE:0:0:0p1/Programme/Firefly Studios/Stronghold Crusader/Stronghold Crusader.exe
Warning: the specified Windows directory L"c:\\windows" is not accessible.
Warning: the specified System directory L"c:\\windows\\system" is not accessible.
wine: cannot find '/media/usb-ITETECHINC-USBTOIDE:0:0:0p1/Programme/Firefly'
linux:~ #

Hmmm. Also ich gleube ich weiss jetzt wo der Fehler liegt.... Kann das sein: Ich habe die Festplatte (Auf welcher ich Windows mit allen Programmen hatte) vom Laptop in ein USB Gehäuse verbannt. Kann das nun sein das hier der Fehler liegt?
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 21. Okt 2005 11:52   Titel:

Wine kann nur auf bestimmte Verzeichnisse zugreifen und zwar eben jene, welche in der Wine-Konfiguration (bei älteren Versionen) angegeben sind, oder welche einen Eintrag unter ~/.wine/dosdevices haben (bei neueren Versionen).

Damit scheint ein Problem vorzuliegen. Poste bitte mal die Ausgabe von

Code:
ls ~/.wine/dosdevices
 
Benutzer-Profile anzeigen Private Nachricht senden

Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 21. Okt 2005 15:57   Titel:

Das ergibt folgendes:

linux:~ # ls ~/.wine/dosdevices
. c: d:: e:: f:: g:: h:: i:: j:: k:: l:: m:: y:
.. d: e: f: g: h: i: j: k: l: m: x: z:
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 21. Okt 2005 17:46   Titel:

Ah sorry, wir brauchen

Code:
ls -l ~/.wine/dosdevices


und "c:" müsste ein symlink auf ~/.wine/drive_c sein, worin sich ein Ordner "windows" befinden müsste.
 
Benutzer-Profile anzeigen Private Nachricht senden

Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 21. Okt 2005 18:11   Titel:

"ls -l ~/.wine/dosdevices" ergibt:

linux:~ # ls -l ~/.wine/dosdevices
total 1
drwxr-xr-x 2 root root 624 Oct 21 11:59 .
drwxr-xr-x 4 root root 216 Oct 21 12:02 ..
lrwxrwxrwx 1 root root 10 Oct 21 11:59 c: -> ../drive_c
lrwxrwxrwx 1 root root 17 Oct 21 11:59 d: -> /media/cdrecorder
lrwxrwxrwx 1 root root 15 Oct 21 11:59 d:: -> /dev/cdrecorder
lrwxrwxrwx 1 root root 31 Oct 21 11:59 e: -> /media/usb-004911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 e:: -> /dev/usb-004911000391:0:0:0p1
lrwxrwxrwx 1 root root 33 Oct 21 11:59 f: -> /media/usb-059B00310200B782:0:0:0
lrwxrwxrwx 1 root root 31 Oct 21 11:59 f:: -> /dev/usb-059B00310200B782:0:0:0
lrwxrwxrwx 1 root root 31 Oct 21 11:59 g: -> /media/usb-114911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 g:: -> /dev/usb-114911000391:0:0:0p1
lrwxrwxrwx 1 root root 31 Oct 21 11:59 h: -> /media/usb-224911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 h:: -> /dev/usb-224911000391:0:0:0p1
lrwxrwxrwx 1 root root 31 Oct 21 11:59 i: -> /media/usb-334911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 i:: -> /dev/usb-334911000391:0:0:0p1
lrwxrwxrwx 1 root root 31 Oct 21 11:59 j: -> /media/usb-554911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 j:: -> /dev/usb-554911000391:0:0:0p1
lrwxrwxrwx 1 root root 31 Oct 21 11:59 k: -> /media/usb-664911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 k:: -> /dev/usb-664911000391:0:0:0p1
lrwxrwxrwx 1 root root 31 Oct 21 11:59 l: -> /media/usb-774911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 l:: -> /dev/usb-774911000391:0:0:0p1
lrwxrwxrwx 1 root root 31 Oct 21 11:59 m: -> /media/usb-884911000391:0:0:0p1
lrwxrwxrwx 1 root root 29 Oct 21 11:59 m:: -> /dev/usb-884911000391:0:0:0p1
lrwxrwxrwx 1 root root 4 Oct 21 11:59 x: -> /tmp
lrwxrwxrwx 1 root root 5 Oct 21 11:59 y: -> /root
lrwxrwxrwx 1 root root 1 Oct 21 11:59 z: -> /
linux:~ #

Habe dann noch nachgesehen, ob der Ordner "Windows existiert. Das tut er nicht. Der Link von "C:" nach "drive_c" ist korrekt, aber es existiert darin kein Ordner:

linux:~ # dir /root/.wine/drive_c
total 0
drwxr-xr-x 2 root root 48 Oct 21 11:59 .
drwxr-xr-x 4 root root 216 Oct 21 12:02 ..
linux:~ # dir /root/.wine/drive_c/windows
/bin/ls: /root/.wine/drive_c/windows: No such file or directory
linux:~ #

Habe dann noch "manuell" nachgesehen und er existiert tatsächlich nicht. Soll ich ihn erstellen oder was soll ich machen?
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 21. Okt 2005 20:01   Titel:

Also eigentlich sollten dort ein Haufen Dateien liegen. So sieht's bei mir aus:

Code:
~/.wine/drive_c/windows/
|-- Application Data
|-- IsUn0407.exe
|-- Start Menu
|   `-- Programs
|       `-- Startup
|-- command
|   `-- start.exe -> /usr/local/lib/wine/start.exe.so
|-- fonts
|-- inf
|   `-- wine.inf
|-- notepad.exe -> /usr/local/lib/wine/notepad.exe.so
|-- profiles
|   |-- Administrator
|   |-- All Users
|   |   |-- Application Data
|   |   |-- Desktop
|   |   |-- Documents
|   |   |-- Favorites
|   |   |-- Start Menu
|   |   |   `-- Programs
|   |   |       `-- StartUp
|   |   `-- Templates
|   `-- maik
|       |-- Cookies
|       |-- Desktop
|       |-- Favorites
|       |-- History
|       |-- My Documents
|       |-- NetHood
|       |-- PrintHood
|       |-- Recent
|       |-- SendTo
|       |-- Start Menu
|       |   `-- Programs
|       |       `-- StartUp
|       |-- Templates
|       `-- Temporary Internet Files
|-- regedit.exe -> /usr/local/lib/wine/regedit.exe.so
|-- rundll32.exe -> /usr/local/lib/wine/rundll32.exe.so
|-- system
|   |-- control.exe -> /usr/local/lib/wine/control.exe.so
|   |-- help.exe -> /usr/local/lib/wine/winhelp.exe.so
|   |-- notepad.exe -> /usr/local/lib/wine/notepad.exe.so
|   |-- progman.exe -> /usr/local/lib/wine/progman.exe.so
|   |-- regsvr32.exe -> /usr/local/lib/wine/regsvr32.exe.so
|   |-- wcmd.exe -> /usr/local/lib/wine/wcmd.exe.so
|   |-- winmine.exe -> /usr/local/lib/wine/winemine.exe.so
|   `-- winver.exe -> /usr/local/lib/wine/winver.exe.so
|-- system.ini
|-- temp
|-- uninstall.exe -> /usr/local/lib/wine/uninstaller.exe.so
|-- win.ini
|-- winebrowser.exe -> /usr/local/lib/wine/winebrowser.exe.so
|-- winhelp.exe -> /usr/local/lib/wine/winhelp.exe.so
`-- winhlp32.exe -> /usr/local/lib/wine/winhelp.exe.so

35 directories, 20 files
 
Benutzer-Profile anzeigen Private Nachricht senden

Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 21. Okt 2005 22:13   Titel:

Hmm, ne, da ist bei mir nichts. Habe jetzt Wine deinstalliert und wieder installiert, hat aber auch nichts gebracht. Drive_c ist und bleibt einfach leer....

Habe mir jetzt mal das Handbuch runtergeladen und werde es lesen. Aber normal ist des schon nicht oder? Ich meine, du musstest doch nichts mehr irgendwo konfigureieren oder so?

Was schlägst du vor?
 
Benutzer-Profile anzeigen Private Nachricht senden

klopskuchen
prolinux-forum-admin


Anmeldungsdatum: 26.06.2004
Beiträge: 1444

BeitragVerfasst am: 21. Okt 2005 22:23   Titel:

Zitat:
Was schlägst du vor?


Zitat:
Habe mir jetzt mal das Handbuch runtergeladen und werde es lesen.

_________________
When all else fails, read the instructions .
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 21. Okt 2005 22:27   Titel:

OKi. Naja, Hast recht Rolling Eyes Sorry
 
Benutzer-Profile anzeigen Private Nachricht senden

Lateralus
prolinux-forum-admin


Anmeldungsdatum: 05.05.2004
Beiträge: 1238

BeitragVerfasst am: 22. Okt 2005 8:27   Titel:

Aber stimmt schon - ich musste desweiteren nichts dafür tun. Du benutzt nicht zufällig SuSE, hm?
 
Benutzer-Profile anzeigen Private Nachricht senden

mohikaner
Gast





BeitragVerfasst am: 22. Okt 2005 9:01   Titel:

Hallo Tinu,

ein
Code:
winecfg
sollte deine Probleme beheben.
 

Tinu



Anmeldungsdatum: 06.08.2005
Beiträge: 27

BeitragVerfasst am: 29. Okt 2005 22:55   Titel:

@Lateralus: Doch, ich benutze SuSE. Wieso? Ist da was anders?

@mohikaner: War ein guter Tipp. Da konnte ich einstellen, das er als c: Nun auf die USB-Festplatte zugreift. Nur... Es funktioniert noch immer nicht:

"ls -l ~/.wine/dosdevices" ergibt nun folgendes:

Martin@linux:~> ls -l ~/.wine/dosdevices
insgesamt 0
lrwxrwxrwx 1 Martin users 39 2005-10-23 18:46 c: -> /media/usb-ITETECHINC-USBTOIDE:0:0:0p1/
lrwxrwxrwx 1 Martin users 17 2005-10-01 13:33 d: -> /media/cdrecorder
lrwxrwxrwx 1 Martin users 15 2005-10-01 13:33 d:: -> /dev/cdrecorder
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 e: -> /media/usb-004911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 e:: -> /dev/usb-004911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 33 2005-10-01 13:33 f: -> /media/usb-059B00310200B782:0:0:0
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 f:: -> /dev/usb-059B00310200B782:0:0:0
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 g: -> /media/usb-224911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 g:: -> /dev/usb-224911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 h: -> /media/usb-774911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 h:: -> /dev/usb-774911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 i: -> /media/usb-884911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 i:: -> /dev/usb-884911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 j: -> /media/usb-BB4911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 j:: -> /dev/usb-BB4911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 k:: -> /dev/usb-CC4911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 l:: -> /dev/usb-DD4911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 31 2005-10-01 13:33 m: -> /media/usb-EE4911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 29 2005-10-01 13:33 m:: -> /dev/usb-EE4911000391:0:0:0p1
lrwxrwxrwx 1 Martin users 4 2005-10-01 13:33 x: -> /tmp
lrwxrwxrwx 1 Martin users 12 2005-10-01 13:33 y: -> /home/Martin
lrwxrwxrwx 1 Martin users 1 2005-10-01 13:33 z: -> /

Wenn ich jedoch ein Programm ausführen will, geht es noch immer nicht:

Martin@linux:~> wine /media/usb-ITETECHINC-USBTOIDE:0:0:0p1/Programme/Messenger/msmsgs.exe
wine: cannot determine executable type for L"C:\\Programme\\Messenger\\msmsgs.exe"
Martin@linux:~>

Frage: Leigt der Fehler vielleicht in der Gross/klein-schreibung des C??? (Nur so eine Vermutung)

oder als Root:

linux:~ # wine /media/usb-ITETECHINC-USBTOIDE:0:0:0p1/Programme/Messenger/msmsgs.exe
Warning: the specified System directory L"c:\\windows\\system" is not accessible.
wine: cannot determine executable type for L"Z:\\media\\usb-ITETECHINC-USBTOIDE:0:0:0p1\\Programme\\Messenger\\msmsgs.exe"
linux:~ #

Was soll jetzt das mit dem Z ???
...
 
Benutzer-Profile anzeigen Private Nachricht senden

mohikaner
Gast





BeitragVerfasst am: 30. Okt 2005 22:54   Titel:

Tinu hat folgendes geschrieben::
Frage: Leigt der Fehler vielleicht in der Gross/klein-schreibung des C??? (Nur so eine Vermutung)


Das glaube ich nicht.
Standartmäßig liegt das Laufwerk C bei wine unter "~/.wine/drive_c". Dahin werden auch alle Programme (sofern möglich) installiert. Wenn du eine andere Partition als Laufwerk C auswählst, müssen dort auch die Systemdateien liegen.
Normalerweise werden die von "winecfg" automatisch angelegt.
Es ist auch möglich eine vorhandene Windowspartition zu verwnden. Die sollte dann natürlich als Laufwerk C konfiguriert sein. In Ermangekung einer Windowspartition kann ich dir dazu leider keine weiteren Tips geben.

mohikaner
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy