Probleme mit der ATI-Grafik

Forum für Leute, die von anderen Systemen auf Linux gewechselt haben oder den Umstieg planen
Antworten
Nachricht
Autor
wechsler

Probleme mit der ATI-Grafik

#1 Beitrag von wechsler » 09. Mär 2006 14:54

Hallo,

ich habe auf meinem rechner erst seit kurzem linux installiert (um genau zu sein kanotix), die Installation lief reibungslos, das system ist auch stabil. Ein Problem habe ich dennoch festgestellt: Wenn ich per Voreinstellung mit KDE starte, sind ja einige Effekte (Transparenz etc.) aktiviert, die für mein Empfinden einer Radeon 9600XT keine so großen Probleme bereiten dürften. Dennoch baut sich die Menüdarstellung etwas schleppend auf, es sei denn, ich deaktiviere diese Spielereien.
Nicht dass ich die Super-Optik bräuchte, aber für Bildbearbeitung wäre mir das schon lieb, das etwas zu beschleunigen. Wenn möglich, ohne große downloads (nur 56k Modem).

Schon mal im Voraus danke.

klopskuchen
prolinux-forum-admin
Beiträge: 1444
Registriert: 26. Jun 2004 21:18
Kontaktdaten:

#2 Beitrag von klopskuchen » 10. Mär 2006 15:12

Ist der ATI-Treiber vielleicht gar nicht aktiv, sondern ein anderer, bzw. ist er in der Datei /etc/X11/xorg.conf in der "section module" eingetragen?


MfG, Klopskuchen
When all else fails, read the instructions .

wechsler

#3 Beitrag von wechsler » 20. Mär 2006 15:01

In dem Abschnitt stehen einige Module, von denen aber keines darauf hindeutet, dass das die Treiber sind.
Folgende sind eingetragen:

ddc, GLcore, dbe, dri, extmod, glx, bitmap, speedo, type1, freetype, record.

Das sagt mir alles nix, aber vielleicht hilft euch das weiter.

klopskuchen
prolinux-forum-admin
Beiträge: 1444
Registriert: 26. Jun 2004 21:18
Kontaktdaten:

#4 Beitrag von klopskuchen » 20. Mär 2006 18:17

Jetzt hab ich mich in die Nassen gesetzt. ;) Als Nicht-ATI-Nutzer kann ich dir auf die Schnelle nicht sagen, welche Treiber genau geladen werden müssen. Bis ein ATI-Nutzer vorbeischaut, kannst du es mir Setupprogrammen probieren: xorgcfg, xorgconf oder xorgsetup.


MfG, Klopskuchen
When all else fails, read the instructions .

Benutzeravatar
Janka
Beiträge: 3585
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 20. Mär 2006 20:22

Das ist ist alles im fglrx-Modul drin. Den gibt man als in der "Device"-Section als Driver an

Code: Alles auswählen

Section "Device"
  BoardName    "IrgendeinBezeichner"
  BusID        "1:0:0"
  Driver       "fglrx"
  Identifier   "Device[0]"
  VendorName   "ATI"
EndSection
FAQ schon durchgearbeitet?

http://www.ati.com/products/catalyst/linux.html

Ganz unten ist auch der passende Link. Leider kann man den wegen des dämlichen Sessionhandlings der ATI-Seite nicht direkt angeben. 4-, ATI.

Janka

Janka

Antworten