Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Ärger mit AGS und Bibliotheken

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 06. Feb 2007 18:48   Titel: Ärger mit AGS und Bibliotheken

Hallo !

Ab und zu spiele ich gerne mal ein Adventure-Spiel. Dazu benutze ich das Adventure Game Studio, von dem es auch eine Linux-Portierung gibt. Bis zur Version 2.71 lief alles ohne Probleme. Mit Version 2.72 gibt es aber ein Problem:

Code:
$ ags
/usr/local/ags/ags: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/ags/ags)


Offensichtlich ist meine libc zu alt, was dpkg bestätigt (2.3.6.ds1-10, Kanotix/Debian Etch). Das wäre ja eigentlich alles nicht so wild, das ganze auf dem eigenen System durchkompilieren und fertig ... doch leider ist AGS Closed-Source, und das wird sich wohl kaum ändern.

Hat jemand ne Idee, wie man das Problem beheben könnte ? Könnte man AGS irgendwie die Version 2.4 der libc unterschieben, evtl. in ner chroot-Umgebung ?
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy