Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
gimp, script-fu und madnriva 2007.1

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Anna
Gast





BeitragVerfasst am: 23. Aug 2007 20:16   Titel: gimp, script-fu und madnriva 2007.1

Hallo,

kennt sich Jemand gut mit Gimp-Scrpting aus?

Ich habe unter Mandriva 2007.1 ein problem, welches es unter 2007.0 nicht gab:
Es funktionieren keine Script-Plugins.

Mdv verwendet die Gimp-Testversion 2.3, wobei ich bei der Mdv 2007.0 auch nicht zu beanstanden hatte, aber bei der aktuellen Versionen kommen dann solche Fehler:

called deprecated procedure 'gimp-palette-get-foreground'.
It should call 'gimp-context-get-foreground' instead!



Code:
Fehler beim Ausführen von
(script-fu-selection-to-anim-image 1 6 10 TRUE TRUE)

Error: set!: unbound variable: selection-bounds


Code:
Fehler beim Ausführen von
(script-fu-gm-color-invert 3 1 6)

Error: set!: unbound variable: new


Code:
Fehler beim Ausführen von
(script-fu-lab-ultra-vivid 1 6 TRUE 0 0 0 TRUE)

Error: set!: unbound variable: uv-layer


Es geht kein Einziges aus meiner Scriptsammling ;(

LG Anna
 

Anna
Gast





BeitragVerfasst am: 24. Aug 2007 14:38   Titel: scheibenkleister

So,

nachdem ich die Empfehlungen der Fehlermeldungen eingebunden habe

Code:
called deprecated procedure 'gimp-palette-get-foreground'.
It should call 'gimp-context-get-foreground' instead!


also sowas im Script mit Suchen/Ersetzen korrigierte, kommen diese Meldungen auch nicht mehr...

jetzt stehe ich bei Fehelrmeldungen, mit dem ich nichts anfangen kann!!!Fehler beim Ausführen von
Code:
(script-fu-calendar 1 2 8 2007 1 0 0 "Sans Bold" '(222 224 207) '(212 94 52) 0)

[code]Error: set!: unbound variable: textBreite [/code]
Plug-In 'Kalender' left image undo in inconsistent state, closing open undo groups.


Da hat man einfach den Gimp-Syntax von Script-Fu geändert und jetzt stehe ich da mit meiner Scriptsammlung - einfach Scheisse
 

sumsi
Gast





BeitragVerfasst am: 28. Aug 2007 9:13   Titel: downgrade

Hallo,

mache ein Downgrad (rpm -Uhv --oldpackage gimp 3.10...rpm).

Gimp scheint sich von der Scheme-Unterstützung zu lösen und favorisiert Python etc.
Ist schade um vorhandene Scripte ..

bye sumsi
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy