Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 20. Nov 2018 22:39

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 26. Aug 2007 11:42 
Offline

Registriert: 26. Aug 2007 11:40
Beiträge: 1
Hallo!

Ich besitze seit kurzem das Toshiba Satego P100-10U Notebook mit Intel HD-Audio ICH7 Soundchip. Nachdem ich nun Debian aufgesetzt habe bekomme ich keinen Sound mehr aus dem DIng, weder aus den integrierten Boxen noch aus dem Headset.


Weiß hier jemand, wie ich vorgehen muss bzw,. was ich installieren soll damit ich endlich auch Sound unter Linux habe?:/

Danke!


Gruß,

NeO


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 27. Aug 2007 10:19 
Offline
prolinux-forum-admin

Registriert: 14. Feb 2003 13:19
Beiträge: 1294
Beschreibe Dein Problem doch etwas genauer.

Spielen Anwendungen Sound ab, oder beschweren sich diese, daß sie keine Soundkarte finden ? In dem Fall ist wahrscheinlich das Kernelmodul nicht geladen.

Die Anwendungen spielen Sound ab, aber Du hörst nichts ? Probiere in den Einstellungen des Soundmixers etwas zu verändern. Mal alles aufdrehen und anmachen, auch wenn's dem Namen nach nichts direkt mit der Abspiellautstärke zu tun hat. Wenn Du den Analogausgang Deiner Soundkarte benutzt, solltest Du alles mit IEC958 im Namen abschalten, das sind die digitalen Ein- und Ausgänge.


Nach oben
   
 Betreff des Beitrags: dis
BeitragVerfasst: 27. Aug 2007 14:20 
Nimm doch einfach eine Distribution, die Dich auch versteht ;-)


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 29. Aug 2007 23:01 
Alsooo:

Es kommt nichts aus den Boxen,weder Systemtöne noch MP§ Files,di zwar scheinbar abgespielt werden (imPlayer jedenfalls)

Zusätzlich wird der Laptop unter Linux verdammt heiss....

Ich schätze mal, das ist alles irgendwie verbunden, denn wenn ich acpi=off schalte, geht der Sound wunderbar und der Laptop bleibt sokühl wie unter Windows, jedoch mit Dauerbelüftung..:/

Wüde ein wechsel zu eienr anderen Distro was bringen?


Nach oben
   
 Betreff des Beitrags: sound
BeitragVerfasst: 30. Aug 2007 8:37 
@ wenn ich acpi=off schalte, geht der Sound wunderbar

Gibt es einen Unterschied in beiden Fällen beim Laden der Module?

# lsmod oder
# lsmod | grep snd


Hier ein Link mit ähnlichen Diskussion:
http://www.linux-club.de/viewtopic.php? ... highlight=

@ Wüde ein wechsel zu eienr anderen Distro was bringen?

Testen, von den verschiedensten distries gibts auch Live-CDs.

Möglicherweise, denn es gibt verschiedene Methoden der Hardwareerkennung und verschieden Kernelversionen.

@ Zusätzlich wird der Laptop unter Linux verdammt heiss....
Dann scheint das Powermanagement nicht zu funktionieren

Ich habe jetzt Mandriva 2007.1 auf mein Laptop installiert .. und so kalt war die Kiste noch nie geblieben..
bye


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 18. Sep 2007 10:44 
Hey!

Habe das problem gelöst: acpi.sourceforge.net, dort auf DSDT gehen und die Anleitung befolgen nachdem man sich die passende DSDT gezogen hat. Habe nun Sound etc.=)


Nach oben
   
 Betreff des Beitrags: DSDT
BeitragVerfasst: 18. Sep 2007 10:48 
Kenne nur GZSZ und GEZ :lol:


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 28. Sep 2007 12:23 
Hab wieder ein Problem:

Hallo!

Ja,und wiedermal ein Problem mit dem Laptop -.- NAchdem ich nun den Sound durch einen neune Kernel behoben habe, habe ich nun neben der nicht funktionierenden TV Karte noch das Problem, dass der Laptop schweine heiss wird. Der Lüfter scheint garnicht zu funktionieren....Ich habe mich mal im Internet schlau gelesen und bin auf das tool fnfx gestoße. DIe installation klappte jedoch nicht, die Fehlermeldung ließ auf folgendes Problem schließen, was auch auf der Seite vermerkt ist:

http://fnfx.sourceforge.net/index.ph...ion=doc#kernel

Code:
To check if ACPI and ACPI Toshiba support are enabled check the following proc entries exists:

/proc/acpi
/proc/acpi/toshiba

If they do exist, FnFX will work on that system. If they do not exist try `modprobe toshiba_acpi' as root. If this throws errors like 'FATAL: Module toshiba_acpi not found' the kernel is most likely not compiled with CONFIG_ACPI and CONFIG_ACPI_TOSHIBA.Das Modul toshiba_acpi ist jedoch vorhanden,nur kann ich es nicht per modprobe aufrufen, weil folgendes bei rauskommt:


Code:
$ modprobe toshiba_acpi
FATAL: Error inserting toshiba_acpi
(.../kernel/drivers/acpi/toshiba_acpi.ko): No such deviceDies wiederum bedeuted scheinbar folgendes:

Code:
This driver does not work on all Toshiba laptops, particularly those models which seem to have a BIOS or other firmware which was not developed by Toshiba itself. New reverse engineering work will have to be done on these machines, or Toshiba will have to disclose the necessary details. The error you will see in this case is:



Das lustige dabei ist:
Total komisch, wenn ich Linux direkt starte kann es passieren,dass der Lüfter läuft oder auch nicht,genauso Bluetooth...Wenn ich aber zuerst Windows starte und dann per reboot ins Linux gehe, dann funktioneirt ALLES....


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 28. Sep 2007 12:42 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Du kannst mal folgendes probieren:

* PnP OS im BIOS-Setup auf "no" stellen.
* APM und oder ACPI ein/ausschalten.
* Default power saving scheme auf "Always on" stellen.
* BIOS-Update

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 9 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de