Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
CPU Last bei VDSL

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Benutzername
Gast





BeitragVerfasst am: 28. Okt 2007 6:57   Titel: CPU Last bei VDSL

Weiß jemand, wie hoch die CPU-Last für einen DSL-Router ist, der ein 5er-Lan zu einem VDSL-Zugang verbinden soll? Ich möchte meinen alten P3/300 gerne als Router weiter benutzen. Außer IP-Weiterleitung und Capisuite für Fax macht er nichts. An meinem 2000er Anschluss bin ich bisher damit gut gefahren, auch während Fax-Übertragung ging die CPU nicht über 30%. Nach dem Umzug gibt es hier kein DSL mehr, nur VDSL (der Kasten steht gleich vorm Haus). Überall heißt es aber, schon für VDSL 25 braucht man mindestens einen 2GHz Rechner und 1GB Ram oder mehr um die Daten schnell genug zu verarbeiten. Und das Fernsehen funktioniert sonst auch nicht (will ich auf jeden Fall haben, hier gibt's kein Kabel und Satellit ist nicht erlaubt).
Was ist dran? Mein momentan schnellster Computer ist nur ein 1,8GHz P4 und hat auch nur 512MB Ram, ich müsste mir dann also einen neuen nur als Router kaufen. Würde ich nur ungern tun und ich möchte auch gleich auf die vollen 50MBit gehen, wenn es schon angeboten wird.
Woran kann es noch alles hängen? System auf dem Router ist Suse 9.3, kann es da mit der Geschwindigkeit Probleme geben? Ist ein Upgrade (habe die 10.3 hier liegen) nötig? Ram ist nur 256MB, das dürfte wohl eng werden. Die Netzwerkkarte zum Modem habe ich getauscht, da war noch eine 10MBit-Karte drin.
Laut Brief von gestern wird morgen früh geschaltet und im Pakte war kein Router dabei. Lieferprobleme, es fehlte auch der Splitter aber den habe ich im T-Punkt bekommen. Und den Telekom-Router will ich ehrlich gesagt auch gar nicht haben, aus verschiedenen Gründen und sehr sehr schlechter Erfahrung mit diesen Geräten.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 28. Okt 2007 15:24   Titel:

Die CPU-Last ist für die Netzwerkgeschwindigkeit gar nicht so entscheidend, wichtig ist, wie schnell das System Interrupts verarbeiten kann. Jedes Paket auf dem Netzwerkinterface löst einen Interrupt aus, und den muss der Prozessor auch in einer angemessenen Zeit verarbeiten können.

VDSL ist immer noch lahmer als dein lokales Ethernet, das fährt schließlich mit 100MBit (oder sogar mehr). Und Fast Ethernet kann jeder Pentium-MMX komplett bedienen. Dein alter Rechner reicht also.

In den fertig aufgebauten (V)DSL-Routern ist auch ein kleiner PC drin, auf MIPS oder ARM-Basis, oft mit Linux oder vxWorks als OS. Das sind aus Energiegründen auch keine GHz-Wunderwerke, und die wenigen Spezialbauteile, die Pakete schnell weiterleiten können, dürften sich auf den integrierten Ethernet-Switch beschränken.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Frankie7
Gast





BeitragVerfasst am: 28. Okt 2007 16:23   Titel:

Die GHz-Angaben beziehen sich auf Windows-Computer, wenn man dort geflashte Online-Videos oder so einen Kram ansehen will. Hier tut es ein Celeron D/800 und auf dem laufen noch andere Dinge wie Bind, kTorrent und aMule und er langweilt sich. Dein Rechner reicht also aus.

>>Die Netzwerkkarte zum Modem habe ich getauscht, da war noch eine 10MBit-Karte drin.

Hoffentlich gegen eine Gigabit-Karte und nicht nur Fast Ethernet. Für VDSL brauchst Du 1504 Jumbo-Frames und das geht nur mit Gigabit. Es sei denn man will zu Basteleien wie reduzierter MTU greifen, was aber manche ACs ablehnen (obwohl sie das nicht dürften).

>>Die CPU-Last ist für die Netzwerkgeschwindigkeit gar nicht so entscheidend, wichtig ist, wie schnell das System Interrupts verarbeiten kann.

Und da wäre eine aktuelle Linux-Version mit der NoHz-Config womöglich von Vorteil. ISDN- und Faxverarbeitung ist auch sehr Interrupt-lastig.

>VDSL ist immer noch lahmer als dein lokales Ethernet, das fährt schließlich mit 100MBit

VDSL2 gibt es seit Oktober auch in 100/25 für die, die 2006 das 55/15 Testprofil bekamen. Nette Sache, vor allem der Upload. Ich musste meinen Switch gegen einen Gigabit tauschen, damit lokal noch Platz ist. Langsam frag ich mich, ob die eines Tages noch 10GBit auf das alte Kupfer kriegen.

>>Woran kann es noch alles hängen?

Man kann das alte Modem nicht einfach gegen ein VDSL-Modem tauschen und es läuft. Da kommt eine VLAN-Konfiguration dazu und zum Fernsehen brauchst Du einen Multicast-Router. Einfach mal bei Google suchen.

>>Und den Telekom-Router will ich ehrlich gesagt auch gar nicht haben

DAS kann ich verstehen. Bei voller Last mit kTorrent und Fernsehen gehen sie schnell in die Knie. Will gar nicht wissen, ob die die 100MBit überhaupt schaffen.
 

Benutzername
Gast





BeitragVerfasst am: 01. Nov 2007 7:32   Titel:

Es funktioniert nicht. Keine Ahnung, was ich falsch mache.
Montag wurde umgeschaltet. Früh habe ich noch das alte DSL-Modem benutzt und es ging. Abends nach Hause gekommen, Capisuite hat den Anruf des Technikers aufgenommen. Alles sei in Ordnung, Anschluss umgeschaltet. Modem gegen das Speedport 300 gewechselt, synchronisiert sich auch sofort. Aber keine Verbindung. Im Systemprotokoll stehen nur PADI-Fehler. Das Kabel zwischen Modem und Computer ist nicht das mitgelieferte, das ist zu kurz. Ich habe es aber auch mal damit versucht. Die LAN-Anzeige am Modem leuchtet jedenfalls und blinkt manchmal beim Verbindungsversuch. ISDN geht, der Anschluss sollte also gehen. Woran liegt es? Dauert es nach dem umschalten eine Weile, bis man sich wieder einwählen kann? Habe ich etwas vergessen? PADI heisst doch, der Zugangsknoten wurde gar nicht gefunden?
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 01. Nov 2007 10:58   Titel:

Sooo ungewöhnlich ist es ja nicht, dass im DSL-Bereich Dinge verkauft werden, die die Techniker dann gar nicht umsetzen können. Das ist ein Fall für deinen DSL-Anbieter, die sollen mal vorbeikommen, und vor Ort nachweisen, dass VDSL funzt.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Krümelchen
Gast





BeitragVerfasst am: 01. Nov 2007 20:47   Titel:

Teste mal, ob es mit dem Telekom-Router geht. Notfalls einen kaufen und dann zurückbringen. Wenn nicht ist die Leitung im Eimer. Wäre nicht ungewöhnlich, bei mir hats drei Versuche gebraucht bis es lief. Geht es damit, liegts wo anders. VDSL wird ganz anders konfiguriert wie ADSL, ich habs nie hinbekommen und mit dann mit dem Router zufrieden geben müssen. Ganz übel ist er nicht, nur beim Fernsehen sollte man nicht gerade große Mail verschicken oder hochladen.
 

Benutzername
Gast





BeitragVerfasst am: 02. Nov 2007 6:49   Titel:

Gestern kam das Paket mit den restlichen Geräten. Ich habe den Router probiert und damit geht es nach Änderung der Netzkonfiguration auf DHCP. Das ist ungünstig. Der Router vergibt nur 192.168.0.* Adressen und ich habe bisher 10.0.0.* benutzt, die leider an vielen Stellen fest eingetragen sind.
Auch bei der Geschwindigkeit gibt es Schwierigkeiten. Wenn ich mit Yast in den Zusatz-Quellen nach Updates suchen lasse, bleibt das Fernsehbild ab und zu stehen. Der Receiver hängt an Port 4, das sollte also nicht passieren.
Aus diesen Gründen würde doch gern wieder meinen eigenen Computer als Router verwenden. Wo muss ich nach dem Fehler suchen? Der Anschluss geht ja.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 02. Nov 2007 11:34   Titel:

Was für ein Router ist das denn?

Die Netzadresse des Routers lässt sich eigentlich immer umstellen, und fest eine MAC-Adresse zugeordnete IP-Adressen können die meisten ebenfalls. Das Fernsehbild bleibt stehen, weil du QoS auf dem Router nicht richtig eingestellt hast, und deshalb Fernsehdaten und Software-Downloads gleich priorisiert *abgefragt* werden. Das wäre mit deinem Eigenbau-Gerät genauso schwierig zu einzustellen oder sogar schwieriger, wenn du wenig Ahnung davon hast.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Krümelchen
Gast





BeitragVerfasst am: 02. Nov 2007 18:43   Titel:

Er schreibt von Paket und Port 4. Dürfte ein W700V oder W701V sein. An den Telekom-Routern ist Port 4 priorisiert. Und es lassen sich feste Adressen einstellen, aber nur im 192.168/16. Damit muss man leben. Ich hätte auch lieber ein Class A Netz, ist schneller zu tippen.
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 02. Nov 2007 19:37   Titel:

Hmm. Der Speedport W700 wird hier
http://wiki.openwrt.org/TableOfHardware
als "Work in Progess" gelistet, demnächst gibt's dafür vielleicht mal eine ordentliche Linux-Distribution.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Jeff
Gast





BeitragVerfasst am: 03. Nov 2007 2:27   Titel:

Wie man den Router mit neuer Software bestückt, findest Du unter: http://wiki.ip-phone-forum.de/skript:speedport2fritz
Eine etwas spärliche aber brauchbare Anleitung für VDSL findet sich direkt bei PL: http://www.pl-berichte.de/berichte/vdsl.html
 

Benutzername
Gast





BeitragVerfasst am: 03. Nov 2007 7:03   Titel:

Ich bin jetzt nach der Anleitung hier auf PL vorgegangen. Auch wenn ich damit die Garantie riskiere. Mein W700V hat jetzt neue Software und läuft scheinbar etwas besser. Ich würde trotzdem gern meinen eigenen Rechner benutzen. Die Angaben zur Konfiguration sind aber für eine andere Version. Gibt es auch eine Anleitung für Suse? Auf die 10.3 habe ich jetzt schon gewechselt.
 

Benutzername
Gast





BeitragVerfasst am: 05. Nov 2007 6:45   Titel:

Mit Hilfe eines Freundes habe ich es hinbekommen. Bei Suse 10.3 haben sich anscheinend einige Dateinamen geändert und die Anleitung funktionierte nicht mehr sofort. Einiges habe ich mir notiert und auch ein volles Backup gemacht.
Der W700V hat wieder seine alte Firmware zurückbekommen und ich schicke ihn heute zurück. Mein eigener Computer ist wirklich besser. Das schnelle Wechseln durch viele Kanäle beim gleichzeitigen Aufnehmen ist kein Problem mehr. Mails senden und Updates holen bringen das Bild nicht mehr aus dem Tritt.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy