trying manual resume from

Antworten
Nachricht
Autor
fanwick
Beiträge: 4
Registriert: 12. Nov 2004 12:09
Wohnort: NRW
Kontaktdaten:

trying manual resume from

#1 Beitrag von fanwick » 10. Nov 2009 21:23

Hallo!
Nach einem regulären Shutdown habe ich meinen Rechner am nächsten Tag wieder gebootet und linux hängt sich auf.

GRUB geht noch, aber danach findet linux seine Partition scheinbar nicht wieder.

Hier einmal ein paar wichtige Dateien:

menu.lst sagt:

# Modified by YaST2. Last modification on Sat Oct 31 01:09:50 CET 2009
default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 - 2.6.27.37-0.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.27.37-0.1-pae root=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296-part3 resume=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296-part2 splash=silent showopts vga=0x31a
initrd /boot/initrd-2.6.27.37-0.1-pae

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.1 - 2.6.27.37-0.1
root (hd0,2)
kernel /boot/vmlinuz-2.6.27.37-0.1-pae root=/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296-part3 showopts ide=nodma apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd-2.6.27.37-0.1-pae

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1

in fstab steht das hier:

/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296-part2 swap swap defaults 0 0
/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296-part3 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296-part1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0


vielleicht ist device.map noch wichtig:

(fd0) /dev/fd0
(hd0) /dev/disk/by-id/ata-SAMSUNG_SP1614N_S016J10X557296




Dann habe ich noch gelesen, dass opensuse in diesem Zusammenhang ganz gerne auch noch in ein paar andere Dateien schreibt - stimmt das?
Mit der opensuse Live CD konnte ich nicht reparieren und auch nicht LIVE booten. Dazu war nur KNOPPIX in der Lage.

Hat jemand eine Idee?
Was ist da passiert?

Gruß, Martin@opensuse11.1

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 11. Nov 2009 12:07

Hast du vor dem Abstellen ein Kernelupdate eingespielt? Wenn ja hast du vermutlich vergessen, vor dem Herunterfahren "mkinitrd" aufzurufen.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

fanwick
Beiträge: 4
Registriert: 12. Nov 2004 12:09
Wohnort: NRW
Kontaktdaten:

#3 Beitrag von fanwick » 11. Nov 2009 13:30

Hallo Janka!

... nicht wissentlich!
Kann das auch mit dem Autoupdate passieren? Und dann auch noch ohne Rückmeldung?
Zumindest gab es keine explizite Aufforderung zum reboot.
----
Martin@openSUSE 11.1

Benutzeravatar
Janka
Beiträge: 3580
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 11. Nov 2009 20:59

Ja, kann auch beim autoupdate passieren. Allerdings sollte er mkinitrd dann auch automatisch aufrufen. Heilen kannst du das ganze, indem du den alten Kernel bootest, oder das Rettungssystem von der SuSE-DVD startest. Da drin mountest du das root-Dateisystem von der Platte, evtl noch /boot, dann chrootest du in das root-Dateisystem. Dann kannst du mkinitrd nachträglich von Hand aufrufen. Falls du zum Booten LILO verwendet hättest, müsstest du den auch noch aufrufen. Bei GRUB reicht mkinitrd.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

fanwick
Beiträge: 4
Registriert: 12. Nov 2004 12:09
Wohnort: NRW
Kontaktdaten:

#5 Beitrag von fanwick » 11. Nov 2009 21:35

Das hört sich gut an.
Werde es mal testen.

Vielen Dank erst einmal! :)
----
Martin@openSUSE 11.1

Antworten