Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
samba will passwort

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Netzwerk
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
nathan99
Gast





BeitragVerfasst am: 09. Okt 2010 0:14   Titel: samba will passwort

]Hi,
ich habe eine Netzwerkfestplatte. Unter Windows kann ich sie ganz einfach erreichen...
Unter linux möchte die Netzwerkfestplatte aber ein passwort haben. ?-)
Ich habe aber kein passwort vergeben und die Netzerkfestplatte "kann" das einendlich auch nicht.
Verstehen tue ich das nicht. ?-)

Kann das eventuell an der smb.conf liegen?
Code:

[global]
#; Die folgende Zeile ist zu entkommentieren,
#; wenn Gästen der Zugriff erlaubt werden soll.
  guest account  = nobody
   log file       = /var/log/samba-log.%m
   lock directory = /var/lock/samba
   share modes    = yes

[homes]
   comment     = Home Directories
   browseable  = no
   read only   = no
   create mode = 0750

[musik]
   comment   = Musik
   path      = /mnt/daten/A-Z
   read only = yes
   public    = yes
aber die ist doch eigendlich für meine freigaben am pc.... (dachte ich)

vll kann mich jemand aufklären...
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Okt 2010 9:35   Titel:

Warum willst du am Samba-Server auf deinem Rechner rumkonfigurieren, wo du doch einzig ein Problem damit hast, SMB bzw. CIFS *auf einem anderen Rechner* anzusprechen?

Wenn deine Netzwerkfestplatte zum Zugriff ein Kennwort haben will, kann das verschiedene Gründe haben. Zum einen kann es sein, dass du einfach nicht mit deren Gastaccount zugreifen willst, sondern mit einem benamten Account zugreifen willst. Wenn dort keine benamten Accounts eingerichtet sind, klappt das natürlich nicht.

Aber wie genau greifst du denn überhaupt auf diese Netzwerkfestplatte zu? Mit einer GUI (welcher?), mit smbclient, mit smbmount oder mit mount -tcifs?

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Nathan99
Gast





BeitragVerfasst am: 09. Okt 2010 17:10   Titel: Hallo Janka,

Danke für deine antwort.
Ich habe versucht über KDE darauf zuzugreifen (also mit smb4k und aus Dolphin heraus)
und ich habe folgendes versucht
Code:

mount -t cifs //192.168.1.202/ /mnt/lan/


immer wird nach einem passwort gefargt...
 

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 09. Okt 2010 17:57   Titel: Re: Hallo Janka,

Nathan99 hat folgendes geschrieben::
Danke für deine antwort.
Ich habe versucht über KDE darauf zuzugreifen (also mit smb4k und aus Dolphin heraus)
und ich habe folgendes versucht

Vermutlich musst du da irgendwo "Gastzugang" einstellen. Ansonsten den Benutzer "guest" ohne Kennwort versuchen.

Zitat:

Code:

mount -t cifs //192.168.1.202/ /mnt/lan/

immer wird nach einem passwort gefargt...

Da fehlt ja auch "-o guest".

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

Nathan99
Gast





BeitragVerfasst am: 09. Okt 2010 21:27   Titel:

Hi,
über KDE geht es mit guest als Benutzernamen und Passwort leer lassen aber wenn ich
Code:
 /sbin/mount.cifs //192.168.1.202/PUBLIC /mnt/lan/ -o nounix,guest,force
oder
Code:
smbclient -U guest -L //192.168.1.202
WARNING: The "share modes" option is deprecated
Enter guest's password:
eigebe gibt es keine reaktion Sad
(ich muss den befehl mit strg+c beenden :-/
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Netzwerk Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy