Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 18. Nov 2018 9:31

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 10 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 11. Jan 2014 21:20 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
Hallo zusammen,
ich habe das Problem, dass ich mich nicht an der Domäne anmelden kann.
Interessant finde ich den Eintrag im log.nmbd:
Zitat:
There is already a domain master browser at IP 192.168.10.2 for workgroup PRAXIS registered on subnet 192.168.10.1.
Der Server auf 192.168.10.2 ist ein Windows 2008 R2 Server. Auf diesem konnte ich allerdings keine Hinweise finden, dass hier ein DC läuft.

Wieso ist denn der Windows 2008 Server als domain master eingetragen?

Später im Log:
Zitat:
Samba name server LINUXSERVER is now a local master browser for workgroup ARBEITSGRUPPE on subnet 192.168.10.1
Denoch kann ich mich von meinem Windows XP Client nicht an der Domäne (LINUXSERVER) anmelden.
Die Fehlermeldung bei der Anmeldung lautet:
Zitat:
Computername ändern
Bei dem Versuch der Domäne "ARBEITSGRUPPE" beizutreten, trat der Folgende Fehler auf:
Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsche Kennwort.
Wo könnte der Fehler liegen?
Wie kann ich feststellen, ob sich der Client am LINUXSERVER oder am Windows Server anmeldet?
Wie kann ich jegliche DC Aktivität am Windows Server unterbinden?

Vielen Dank für Eure Hilfe!
Alex


Zuletzt geändert von Dr.Wackelzahn am 12. Jan 2014 14:04, insgesamt 1-mal geändert.

Nach oben
   
BeitragVerfasst: 11. Jan 2014 22:59 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
Hallo zusammen,
ich habe das Problem, dass ich mich nicht an der Domäne anmelden kann.
Interessant finde ich den Eintrag im log.nmbd:
Zitat:
There is already a domain master browser at IP 192.168.10.2 for workgroup PRAXIS registered on subnet 192.168.10.1.
Der Server auf 192.168.10.2 ist ein Windows 2008 R2 Server. Auf diesem konnte ich allerdings keine Hinweise finden, dass hier ein DC läuft.
Du hast vermutlich irgendwo die Kompatibilität zu WindowsNT-Domänen eingeschaltet. Da ist der Domain Master Browser mit drin. Das ist aber ohnehin eine eher Informative Meldung, die mit dem Problem unten nichts zu tun hat.
Zitat:
Zitat:
Samba name server LINUXSERVER is now a local master browser for workgroup ARBEITSGRUPPE on subnet 192.168.10.1
Denoch kann ich mich von meinem Windows XP Client nicht an der Domäne (LINUXSERVER) anmelden.
Das ist ein Missverständnis. Der "Master Browser" hat nichts mit der Domänenanmeldung zu tun. Er ist ausschließlich dafür da, die per Broadcast ermittelten Computernameslisten zu verbreiten.
Zitat:
Die Fehlermeldung bei der Anmeldung lautet:
Zitat:
Computername ändern
Bei dem Versuch der Domäne "ARBEITSGRUPPE" beizutreten, trat der Folgende Fehler auf:
Anmeldung fehlgeschlagen: unbekannter Benutzername oder falsche Kennwort.
Wo könnte der Fehler liegen?
Dazu müsste man die komplette smb.conf sehen. Ist das Samba3 oder Samba4?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Jan 2014 0:33 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
Code:
[global]
        restrict anonymous = 0
        socket options = TCP_NODELAY
        interfaces = eth0/192.168.10.1 192.168.10.1
        passwd program = /usr/bin/passwd %u
        netbios name = LINUXSERVER

        printing = cups
        printcap cache time = 750
        cups options = raw

        server string = %h
        kernel oplocks = Yes
        unix password sync = Yes
        dos charset = cp1252
        workgroup = ARBEITSGRUPPE
        encrypt passwords = yes
        os level = 100
        set primary group script = /usr/sbin/usermod -g "%g" "%u"
        security = user
        unix charset = UTF-8
        bind interfaces only = True
        pam password change = Yes
        client schannel = no
        server schannel = no
        smb ports = 445

        profile acls = Yes

#       include = /etc/samba/dhcp.conf
        logon drive = Z:
        domain master = Yes
        map to guest = Bad User
        logon home = \\%L\%U\.9xprofile
        passdb backend = tdbsam
        logon path = \\%L\profiles\.msprofile
        printcap name = cups
        usershare allow guests = Yes
        domain logons = Yes

        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        add user script = /usr/sbin/useradd -m %u
        delete user script = /usr/sbin/userdel -r %u
        delete group script = /usr/sbin/groupdel %g
        add user to group script = /usr/sbin/usermod -G %g %u

#       add machine script = /usr/sbin/useradd -s /bin/false -d /dev/null %u
        add group script = /etc/samba/smbgrpadd.sh "%g"

        local master = Yes
        time server = Yes
        deadtime = 15
        preferred master = Yes
        wins support = Yes
        client ntlmv2 auth = No
[homes]
        comment = Home Directories
        path = /home/%u
        read only = No # schreiben ist erlaubt
        browseable = No # der share ist nicht sichtbar

[netlogon]
        comment = Network Logon Service
        path = /var/lib/samba/netlogon
        write list = root
Es ist Samba 3


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Jan 2014 3:45 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Mit welchem Benutzer authentifizierst du dich beim Anmelden an die Domäne? root? Das ist bei manchen Windows-Version zwangsweise der Benutzername, mit dem du dich lokal angemeldet hast. Samba-seitig muss es root sein, oder du musst in /etc/samba/smbusers ein Mapping einstellen. War der Client zuvor schon einmal in einer Domäne? Man muss zwischen Domänenwechseln immer erst einmal "Arbeitsgruppe" auf dem Client einstellen und neu booten, sonst klappt es einfach nicht.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Jan 2014 9:55 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
Hallo Janka,
vielen Dank für die Tipps! In smbusers hatte ich folgenden Eintrag gemacht:
Code:
root = administrator
;nobody = guest pcguest smbguest
Ich glaube nicht, dass sich der PC schon einmal an einer Domäne angemeldet hat. Aber ich kann ja mal die Arbeitsgruppe hin und her-ändern.
Melde mich dann wieder.

Angemeldet habe ich mich root und dem Passwort welches ich beim Anlegen erstellt habe.

Gruß,
Alexander


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Jan 2014 10:05 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
So, ich hatte nun die Arbeitsgruppe geändert, neugestartet und dann wieder versucht mich an der Domäne anzumelden. Ohne Erfolg, leider. Wo kann ich sehen, ob sich mein Client tatsächlich an meinem LINUXSERVER anmeldet und nicht doch am Windows Server?
Welche Log-Files könnten noch interessant sein?

Gruß,
Alex


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Jan 2014 11:23 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
Ich bin schon soweit, dass ich das ganze neu Aufsetze. Kennt jemand ein wirklich gutes Tutorial für Samba 3 für PDC und Windows XP, 7 und Windows Server 2008?

Ich finde den Fehler einfach nicht. :?

Vielen Dank und Gruß,
Alex


Nach oben
   
 Betreff des Beitrags: Dem Rätsel auf der Spur
BeitragVerfasst: 12. Jan 2014 13:14 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
habe nun die smb.conf gelöscht und das Muster von http://wiki.ubuntuusers.de/Samba_Server_PDC genommen.
Alles entsprechend angelegt und siehe da, es funktioniert.

Jetzt habe ich in der funktionierenden smb.conf den Eintrag workgroup auf mein Netzwerk angepasst und ich habe das gleiche Problem wie vorher. Ändere ich den Eintrag in einen beliebigen anderen, geht die Anmeldung wieder.

Wieso kann ich nicht meinen bisherigen workgroup Namen nehmen?
Vielen Dank für Tipps,
Gruß,
Alex


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Jan 2014 13:38 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
Ich habe immer noch den Eindruck das meine Anfragen bei der Anmeldung der Domäne nicht von meinem LINUXSERVER sondern von irgendwem anders beantwortet werden.
Wie bekomme ich raus, wer sich im Netz noch als entsprechender Domänencontroller ausgibt?


Nach oben
   
 Betreff des Beitrags: [Gelöst]
BeitragVerfasst: 12. Jan 2014 14:04 
Offline

Registriert: 11. Jan 2014 20:54
Beiträge: 9
Mea culpa!

Ich hatte vor Jahren einen weiteren Server installiert und damals diesen als PDC eingerichtet. Allerdings habe ich diesen dann aus Zeitgründen nicht als PDC genutzt und die Sache ganz vergessen.

Habe nun den PDC dort deaktiviert und jetzt läuft alles wieder.

Naja, so habe ich mal wieder meine smb.conf aufgeräumt.

Trotzdem vielen dank für Deine Unterstützung Janka!


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 10 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de