Login


 
Newsletter
Werbung

Sicherheit: Zwei Probleme in kvm
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in kvm
ID: SUSE-SU-2016:0010-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Desktop 11-SP4
Datum: Mo, 4. Januar 2016, 23:50
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7512
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-8345

Originalnachricht

   SUSE Security Update: Security update for kvm
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:0010-1
Rating: important
References: #947164 #950590 #953187 #956829 #957162
Cross-References: CVE-2015-7512 CVE-2015-8345
Affected Products:
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Desktop 11-SP4
______________________________________________________________________________

An update that solves two vulnerabilities and has three
fixes is now available.

Description:


This update for kvm fixes the following issues:

Security issues fixed:
- CVE-2015-7512: The receive packet size is now checked in the emulated
pcnet driver, eliminating buffer overflow and potential security issue
by malicious guest systems. (bsc#957162)
- CVE-2015-8345: A infinite loop in processing command block list was
fixed that could be exploit by malicious guest systems (bsc#956829).

Other bugs fixed:
- To assist users past the migration incompatibility discussed in
bsc#950590 (restore migration compatibility with SLE11 SP3 and SLE12, at
the unfortunate expense to prior SLE11 SP4 kvm release compatability
when a virtio-net device is used), print a message which references the
support document TID 7017048. See
https://www.suse.com/support/kb/doc.php?id=7017048
- Fix cases of wrong clock values in kvmclock timekeeping (bsc#947164 and
bsc#953187)
- Enforce pxe rom sizes to ensure migration compatibility. (bsc#950590)
- Fix kvm live migration fails between sles11 sp3 and sp4 (bsc#950590)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-kvm-12293=1

- SUSE Linux Enterprise Desktop 11-SP4:

zypper in -t patch sledsp4-kvm-12293=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11-SP4 (i586 s390x x86_64):

kvm-1.4.2-35.1

- SUSE Linux Enterprise Desktop 11-SP4 (i586 x86_64):

kvm-1.4.2-35.1


References:

https://www.suse.com/security/cve/CVE-2015-7512.html
https://www.suse.com/security/cve/CVE-2015-8345.html
https://bugzilla.suse.com/947164
https://bugzilla.suse.com/950590
https://bugzilla.suse.com/953187
https://bugzilla.suse.com/956829
https://bugzilla.suse.com/957162

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung