Login
Login-Name Passwort


 
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Squid
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Squid
ID: SUSE-SU-2016:1996-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 11-SP4, SUSE Linux Enterprise Debuginfo 11-SP4
Datum: Di, 9. August 2016, 22:39
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4053
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-7142
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4553
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0128
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-7141
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-5643
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4054
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-6270
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-0188
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4554
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5400
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2572
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2571
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-3948
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2570
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-3947
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3205
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2390
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4051
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4096
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4556
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4052
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-4555
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4115
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-2569

Originalnachricht

   SUSE Security Update: Security update for squid3
______________________________________________________________________________

Announcement ID: SUSE-SU-2016:1996-1
Rating: important
References: #895773 #902197 #938715 #963539 #967011 #968392
#968393 #968394 #968395 #973782 #973783 #976553
#976556 #976708 #979008 #979009 #979010 #979011

Cross-References: CVE-2011-3205 CVE-2011-4096 CVE-2012-5643
CVE-2013-0188 CVE-2013-4115 CVE-2014-0128
CVE-2014-6270 CVE-2014-7141 CVE-2014-7142
CVE-2015-5400 CVE-2016-2390 CVE-2016-2569
CVE-2016-2570 CVE-2016-2571 CVE-2016-2572
CVE-2016-3947 CVE-2016-3948 CVE-2016-4051
CVE-2016-4052 CVE-2016-4053 CVE-2016-4054
CVE-2016-4553 CVE-2016-4554 CVE-2016-4555
CVE-2016-4556
Affected Products:
SUSE Linux Enterprise Server 11-SP4
SUSE Linux Enterprise Debuginfo 11-SP4
______________________________________________________________________________

An update that fixes 25 vulnerabilities is now available.

Description:



This update for squid3 fixes the following issues:

- Multiple issues in pinger ICMP processing. (CVE-2014-7141,
CVE-2014-7142)

- CVE-2016-3947: Buffer overrun issue in pinger ICMPv6 processing.
(bsc#973782)

- CVE-2016-4554: fix header smuggling issue in HTTP Request processing
(bsc#979010)

- fix multiple Denial of Service issues in HTTP Response processing.
(CVE-2016-2569, CVE-2016-2570, CVE-2016-2571, CVE-2016-2572, bsc#968392,
bsc#968393, bsc#968394, bsc#968395)

- CVE-2016-3948: Fix denial of service in HTTP Response processing
(bsc#973783)

- CVE-2016-4051: fixes buffer overflow in cachemgr.cgi (bsc#976553)

- CVE-2016-4052, CVE-2016-4053, CVE-2016-4054:
* fixes multiple issues in ESI processing (bsc#976556)

- CVE-2016-4556: fixes double free vulnerability in Esi.cc (bsc#979008)

- CVE-2015-5400: Improper Protection of Alternate Path (bsc#938715)

- CVE-2014-6270: fix off-by-one in snmp subsystem (bsc#895773)

- Memory leak in squid3 when using external_acl (bsc#976708)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11-SP4:

zypper in -t patch slessp4-squid3-12682=1

- SUSE Linux Enterprise Debuginfo 11-SP4:

zypper in -t patch dbgsp4-squid3-12682=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11-SP4 (i586 ia64 ppc64 s390x x86_64):

squid3-3.1.23-8.16.27.1

- SUSE Linux Enterprise Debuginfo 11-SP4 (x86_64):

squid3-debuginfo-3.1.23-8.16.27.1


References:

https://www.suse.com/security/cve/CVE-2011-3205.html
https://www.suse.com/security/cve/CVE-2011-4096.html
https://www.suse.com/security/cve/CVE-2012-5643.html
https://www.suse.com/security/cve/CVE-2013-0188.html
https://www.suse.com/security/cve/CVE-2013-4115.html
https://www.suse.com/security/cve/CVE-2014-0128.html
https://www.suse.com/security/cve/CVE-2014-6270.html
https://www.suse.com/security/cve/CVE-2014-7141.html
https://www.suse.com/security/cve/CVE-2014-7142.html
https://www.suse.com/security/cve/CVE-2015-5400.html
https://www.suse.com/security/cve/CVE-2016-2390.html
https://www.suse.com/security/cve/CVE-2016-2569.html
https://www.suse.com/security/cve/CVE-2016-2570.html
https://www.suse.com/security/cve/CVE-2016-2571.html
https://www.suse.com/security/cve/CVE-2016-2572.html
https://www.suse.com/security/cve/CVE-2016-3947.html
https://www.suse.com/security/cve/CVE-2016-3948.html
https://www.suse.com/security/cve/CVE-2016-4051.html
https://www.suse.com/security/cve/CVE-2016-4052.html
https://www.suse.com/security/cve/CVE-2016-4053.html
https://www.suse.com/security/cve/CVE-2016-4054.html
https://www.suse.com/security/cve/CVE-2016-4553.html
https://www.suse.com/security/cve/CVE-2016-4554.html
https://www.suse.com/security/cve/CVE-2016-4555.html
https://www.suse.com/security/cve/CVE-2016-4556.html
https://bugzilla.suse.com/895773
https://bugzilla.suse.com/902197
https://bugzilla.suse.com/938715
https://bugzilla.suse.com/963539
https://bugzilla.suse.com/967011
https://bugzilla.suse.com/968392
https://bugzilla.suse.com/968393
https://bugzilla.suse.com/968394
https://bugzilla.suse.com/968395
https://bugzilla.suse.com/973782
https://bugzilla.suse.com/973783
https://bugzilla.suse.com/976553
https://bugzilla.suse.com/976556
https://bugzilla.suse.com/976708
https://bugzilla.suse.com/979008
https://bugzilla.suse.com/979009
https://bugzilla.suse.com/979010
https://bugzilla.suse.com/979011

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung