Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in gmime2.2
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in gmime2.2
ID: DSA-2082-1
Distribution: Debian
Plattformen: Debian lenny, Debian sid
Datum: Mo, 2. August 2010, 08:24
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0409
Applikationen: gmime2.2

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA-2082-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
August 02, 2010 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : gmime2.2
Vulnerability : buffer overflow
Problem type : local(remote)
Debian-specific: no
CVE Id(s) : CVE-2010-0409

It was discovered that a buffer overflow in the MIME library GMime might
lead to the execution of arbitrary code.

For the stable distribution (lenny), this problem has been fixed in
version 2.2.22-2+lenny2.

For the unstable distribution (sid), this problem has been fixed in
version 2.2.25-1.1.

We recommend that you upgrade your gmime2.2 packages.

Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Stable updates are available for alpha, amd64, arm, armel, hppa, i386, ia64,
mips, mipsel, powerpc, s390 and sparc.

Source archives:

gmime2.2_2.2.22-2+lenny2.dsc
Size/MD5 checksum: 1401 ee8a3bfc09aaa29c015ed41c5c64b67f
gmime2.2_2.2.22.orig.tar.gz
Size/MD5 checksum: 1064237 c5c2cd8c94dc26b18c5524d70eb2971d
gmime2.2_2.2.22-2+lenny2.diff.gz
Size/MD5 checksum: 17500 dd72f21c5228d428c826f95a80fbe411

Architecture independent packages:

libgmime2.2-cil_2.2.22-2+lenny2_all.deb
Size/MD5 checksum: 108528 9e3d64264b125ad02bdfd63f4140c5a0
libgmime-2.0-2-doc_2.2.22-2+lenny2_all.deb
Size/MD5 checksum: 180604 c8c63b434d77e75f3a5119946f1bc9ad

alpha architecture (DEC Alpha)

libgmime-2.0-2a_2.2.22-2+lenny2_alpha.deb
Size/MD5 checksum: 225274 23d66bf390138fbac4fa410a20343cc2
libgmime-2.0-2-dev_2.2.22-2+lenny2_alpha.deb
Size/MD5 checksum: 347220 cb4e8e5d8b06ade540827d8688e7f77a

amd64 architecture (AMD x86_64 (AMD64))

libgmime-2.0-2-dev_2.2.22-2+lenny2_amd64.deb
Size/MD5 checksum: 275366 fc179fa46f2c04ba4f3780e76452bc59
libgmime-2.0-2a_2.2.22-2+lenny2_amd64.deb
Size/MD5 checksum: 212108 656635df2abd04863d0dfd4f743505ff

arm architecture (ARM)

libgmime-2.0-2a_2.2.22-2+lenny2_arm.deb
Size/MD5 checksum: 193486 806b92435d3e9f54f822f93d6565381a
libgmime-2.0-2-dev_2.2.22-2+lenny2_arm.deb
Size/MD5 checksum: 255280 584045a97ea6d10dd8222b86777677f8

armel architecture (ARM EABI)

libgmime-2.0-2-dev_2.2.22-2+lenny2_armel.deb
Size/MD5 checksum: 255824 c6ddb0454fd77cf97761abe97b5d8da1
libgmime-2.0-2a_2.2.22-2+lenny2_armel.deb
Size/MD5 checksum: 196376 0c3d19cc7ec906a468b24a3dde738a7d

hppa architecture (HP PA RISC)

libgmime-2.0-2-dev_2.2.22-2+lenny2_hppa.deb
Size/MD5 checksum: 298224 d3f0860f1e26f1c34c06bac16d9d3ac3
libgmime-2.0-2a_2.2.22-2+lenny2_hppa.deb
Size/MD5 checksum: 224606 e7a807b9e7a8a676a8870589a832ffce

i386 architecture (Intel ia32)

libgmime-2.0-2a_2.2.22-2+lenny2_i386.deb
Size/MD5 checksum: 201216 cc47e2077eeda73b680afed854ef69b1
libgmime-2.0-2-dev_2.2.22-2+lenny2_i386.deb
Size/MD5 checksum: 253906 69891fcb89d04b5d4645e5c7ee660583

ia64 architecture (Intel ia64)

libgmime-2.0-2-dev_2.2.22-2+lenny2_ia64.deb
Size/MD5 checksum: 353182 e0c8c457c0951e8726ab8d676975efd9
libgmime-2.0-2a_2.2.22-2+lenny2_ia64.deb
Size/MD5 checksum: 263144 47d7efaa2f0b20d2b88c75aeff9910a7

mipsel architecture (MIPS (Little Endian))

libgmime-2.0-2a_2.2.22-2+lenny2_mipsel.deb
Size/MD5 checksum: 197096 cfb1d5013aecea561e200c4b918cb064
libgmime-2.0-2-dev_2.2.22-2+lenny2_mipsel.deb
Size/MD5 checksum: 294200 cfaaca5779c560adf0f558fc1176a6bf

s390 architecture (IBM S/390)

libgmime-2.0-2-dev_2.2.22-2+lenny2_s390.deb
Size/MD5 checksum: 278084 f63c943d92c5ddf940f110aefcf6bdc9
libgmime-2.0-2a_2.2.22-2+lenny2_s390.deb
Size/MD5 checksum: 222436 2b4e56e87b682bfd545573bead6b343e

sparc architecture (Sun SPARC/UltraSPARC)

libgmime-2.0-2-dev_2.2.22-2+lenny2_sparc.deb
Size/MD5 checksum: 265136 25a897c072a4011d12a72408fc510aa0
libgmime-2.0-2a_2.2.22-2+lenny2_sparc.deb
Size/MD5 checksum: 202074 153bc80b2109ee1ed7659f03aa291bd0


These files will probably be moved into the stable distribution on
its next update.

-
---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-securitydists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkxWR4kACgkQXm3vHE4uylqu3QCgqw2IHa0E232rabSVi9wupxCO
lvsAnixyHbj5wgv9GRaHHZ03TMTS2xBn
=49Aj
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: http://lists.debian.org/20100802042400.GA12190@galadriel.inutil.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung