Login
Newsletter
Werbung

Sicherheit: Überschreiben von Dateien in OpenShift
Aktuelle Meldungen Distributionen
Name: Überschreiben von Dateien in OpenShift
ID: RHSA-2018:1233-01
Distribution: Red Hat
Plattformen: Red Hat OpenShift Enterprise
Datum: Mo, 30. April 2018, 09:09
Referenzen: https://access.redhat.com/security/cve/CVE-2018-1102
Applikationen: OpenShift

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: OpenShift Container Platform 3.6 security and bug
fix update
Advisory ID: RHSA-2018:1233-01
Product: Red Hat OpenShift Enterprise
Advisory URL: https://access.redhat.com/errata/RHSA-2018:1233
Issue date: 2018-04-30
CVE Names: CVE-2018-1102
=====================================================================

1. Summary:

An update is now available for Red Hat OpenShift Container Platform 3.6.

Red Hat Product Security has rated this update as having a security impact
of Critical. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat OpenShift Container Platform 3.6 - noarch, x86_64

3. Description:

Red Hat OpenShift Container Platform is the company's cloud computing
Platform-as-a-Service (PaaS) solution designed for on-premise or private
cloud deployments.

This advisory contains RPM packages for this release. See the following
advisory for the container images for this release:

https://access.redhat.com/errata/RHBA-2018:1232

Security Fix(es):

* source-to-image: Improper path sanitization in
ExtractTarStreamFromTarReader in tar/tar.go (CVE-2018-1102)

This update also fixes the following bugs:

* Image validation used to validate old image objects, and an invalid image
could be pushed to etcd. With this bug fix, validation has been changed to
validate new image objects, and as a result it is no longer possible to
upload an invalid image object. (BZ#1559982)

* A panic could occur due to concurrent writes to cache. This bug fix
protects writes to the cache with mutex. As a result, the cache is safe to
use concurrently. (BZ#1549916)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1490989 - Maximal ebs-volumes of an ec2-instance: 52/54?
1549916 - [3.6][Backport] internal image registry was down due to data race
1554866 - [3.6] subpath volume mounts do not work with secret, configmap,
projected, or downwardAPI volumes
1556796 - [3.6] Mounting file in a subpath fails if file was created in
initContainer
1559670 - [3.6] Fail to update EFK: 'namespace'
1559982 - [3.6][Backport] oc adm migrate storage produces error as signature
annotations forbidden
1561236 - Kubernetes Patch request - "CreateContainerConfigError: failed to
prepare subPath for volumeMount" error with configMap volume
1562246 - CVE-2018-1102 source-to-image: Improper path sanitization in
ExtractTarStreamFromTarReader in tar/tar.go
1563317 - Mounting socket files from subPaths fail

6. Package List:

Red Hat OpenShift Container Platform 3.6:

Source:
atomic-openshift-3.6.173.0.113-1.git.0.65fb9fb.el7.src.rpm
rubygem-cool.io-1.5.3-1.el7.src.rpm
rubygem-excon-0.60.0-1.el7.src.rpm
rubygem-faraday-0.13.1-1.el7.src.rpm
rubygem-ffi-1.9.23-1.el7.src.rpm
rubygem-fluent-plugin-kubernetes_metadata_filter-1.0.1-1.el7.src.rpm
rubygem-fluent-plugin-systemd-0.0.9-1.el7.src.rpm
rubygem-minitest-5.10.3-1.el7.src.rpm
rubygem-msgpack-1.2.2-1.el7.src.rpm
rubygem-multi_json-1.13.1-1.el7.src.rpm
rubygem-systemd-journal-1.3.1-1.el7.src.rpm
rubygem-tzinfo-1.2.5-1.el7.src.rpm
rubygem-tzinfo-data-1.2018.3-1.el7.src.rpm
rubygem-unf_ext-0.0.7.5-1.el7.src.rpm

noarch:
atomic-openshift-docker-excluder-3.6.173.0.113-1.git.0.65fb9fb.el7.noarch.rpm
atomic-openshift-excluder-3.6.173.0.113-1.git.0.65fb9fb.el7.noarch.rpm
rubygem-cool.io-doc-1.5.3-1.el7.noarch.rpm
rubygem-excon-0.60.0-1.el7.noarch.rpm
rubygem-excon-doc-0.60.0-1.el7.noarch.rpm
rubygem-faraday-0.13.1-1.el7.noarch.rpm
rubygem-faraday-doc-0.13.1-1.el7.noarch.rpm
rubygem-fluent-plugin-kubernetes_metadata_filter-1.0.1-1.el7.noarch.rpm
rubygem-fluent-plugin-kubernetes_metadata_filter-doc-1.0.1-1.el7.noarch.rpm
rubygem-fluent-plugin-systemd-0.0.9-1.el7.noarch.rpm
rubygem-fluent-plugin-systemd-doc-0.0.9-1.el7.noarch.rpm
rubygem-minitest-5.10.3-1.el7.noarch.rpm
rubygem-minitest-doc-5.10.3-1.el7.noarch.rpm
rubygem-msgpack-doc-1.2.2-1.el7.noarch.rpm
rubygem-multi_json-1.13.1-1.el7.noarch.rpm
rubygem-multi_json-doc-1.13.1-1.el7.noarch.rpm
rubygem-systemd-journal-1.3.1-1.el7.noarch.rpm
rubygem-systemd-journal-doc-1.3.1-1.el7.noarch.rpm
rubygem-tzinfo-1.2.5-1.el7.noarch.rpm
rubygem-tzinfo-data-1.2018.3-1.el7.noarch.rpm
rubygem-tzinfo-data-doc-1.2018.3-1.el7.noarch.rpm
rubygem-tzinfo-doc-1.2.5-1.el7.noarch.rpm
rubygem-unf_ext-doc-0.0.7.5-1.el7.noarch.rpm

x86_64:
atomic-openshift-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-clients-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-clients-redistributable-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rp
m
atomic-openshift-cluster-capacity-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-dockerregistry-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-federation-services-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rp
m
atomic-openshift-master-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-node-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-pod-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-sdn-ovs-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-service-catalog-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
atomic-openshift-tests-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rpm
rubygem-cool.io-1.5.3-1.el7.x86_64.rpm
rubygem-cool.io-debuginfo-1.5.3-1.el7.x86_64.rpm
rubygem-ffi-1.9.23-1.el7.x86_64.rpm
rubygem-ffi-debuginfo-1.9.23-1.el7.x86_64.rpm
rubygem-msgpack-1.2.2-1.el7.x86_64.rpm
rubygem-msgpack-debuginfo-1.2.2-1.el7.x86_64.rpm
rubygem-unf_ext-0.0.7.5-1.el7.x86_64.rpm
rubygem-unf_ext-debuginfo-0.0.7.5-1.el7.x86_64.rpm
tuned-profiles-atomic-openshift-node-3.6.173.0.113-1.git.0.65fb9fb.el7.x86_64.rp
m

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-1102
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2018 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFa5pUDXlSAg2UNWIIRAsugAKCpo7iRBSR962dtm5QhtpRzePj6TwCdED97
0/aYFd+9bGWK8sJMEVR440U=
=KFYZ
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://www.redhat.com/mailman/listinfo/rhsa-announce
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung