Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in php7
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in php7
ID: SUSE-SU-2018:2333-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Web Scripting 12, SUSE Linux Enterprise Software Development Kit 12-SP3
Datum: Do, 16. August 2018, 09:16
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9120
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-14851
Applikationen: PHP

Originalnachricht

   SUSE Security Update: Security update for php7
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:2333-1
Rating: moderate
References: #1103659 #1103661
Cross-References: CVE-2017-9120 CVE-2018-14851
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Module for Web Scripting 12
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for php7 fixes the following issues:

The following security vulnerabilities were fixed:

- CVE-2018-14851: Fixed an out-of-bound read in
exif_process_IFD_in_MAKERNOTE, which could be exploited by an attacker
via crafted JPG files, and could result in an application crash.
(bsc#1103659)

- CVE-2017-9120: Fixed an buffer overflow in mysqli_real_escape_string,
which could be exploited via along string and could result in an
application crash
or have other unspecified impacts. (bsc#1103661)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-1571=1

- SUSE Linux Enterprise Module for Web Scripting 12:

zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2018-1571=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

php7-debuginfo-7.0.7-50.44.1
php7-debugsource-7.0.7-50.44.1
php7-devel-7.0.7-50.44.1

- SUSE Linux Enterprise Module for Web Scripting 12 (aarch64 ppc64le s390x
x86_64):

apache2-mod_php7-7.0.7-50.44.1
apache2-mod_php7-debuginfo-7.0.7-50.44.1
php7-7.0.7-50.44.1
php7-bcmath-7.0.7-50.44.1
php7-bcmath-debuginfo-7.0.7-50.44.1
php7-bz2-7.0.7-50.44.1
php7-bz2-debuginfo-7.0.7-50.44.1
php7-calendar-7.0.7-50.44.1
php7-calendar-debuginfo-7.0.7-50.44.1
php7-ctype-7.0.7-50.44.1
php7-ctype-debuginfo-7.0.7-50.44.1
php7-curl-7.0.7-50.44.1
php7-curl-debuginfo-7.0.7-50.44.1
php7-dba-7.0.7-50.44.1
php7-dba-debuginfo-7.0.7-50.44.1
php7-debuginfo-7.0.7-50.44.1
php7-debugsource-7.0.7-50.44.1
php7-dom-7.0.7-50.44.1
php7-dom-debuginfo-7.0.7-50.44.1
php7-enchant-7.0.7-50.44.1
php7-enchant-debuginfo-7.0.7-50.44.1
php7-exif-7.0.7-50.44.1
php7-exif-debuginfo-7.0.7-50.44.1
php7-fastcgi-7.0.7-50.44.1
php7-fastcgi-debuginfo-7.0.7-50.44.1
php7-fileinfo-7.0.7-50.44.1
php7-fileinfo-debuginfo-7.0.7-50.44.1
php7-fpm-7.0.7-50.44.1
php7-fpm-debuginfo-7.0.7-50.44.1
php7-ftp-7.0.7-50.44.1
php7-ftp-debuginfo-7.0.7-50.44.1
php7-gd-7.0.7-50.44.1
php7-gd-debuginfo-7.0.7-50.44.1
php7-gettext-7.0.7-50.44.1
php7-gettext-debuginfo-7.0.7-50.44.1
php7-gmp-7.0.7-50.44.1
php7-gmp-debuginfo-7.0.7-50.44.1
php7-iconv-7.0.7-50.44.1
php7-iconv-debuginfo-7.0.7-50.44.1
php7-imap-7.0.7-50.44.1
php7-imap-debuginfo-7.0.7-50.44.1
php7-intl-7.0.7-50.44.1
php7-intl-debuginfo-7.0.7-50.44.1
php7-json-7.0.7-50.44.1
php7-json-debuginfo-7.0.7-50.44.1
php7-ldap-7.0.7-50.44.1
php7-ldap-debuginfo-7.0.7-50.44.1
php7-mbstring-7.0.7-50.44.1
php7-mbstring-debuginfo-7.0.7-50.44.1
php7-mcrypt-7.0.7-50.44.1
php7-mcrypt-debuginfo-7.0.7-50.44.1
php7-mysql-7.0.7-50.44.1
php7-mysql-debuginfo-7.0.7-50.44.1
php7-odbc-7.0.7-50.44.1
php7-odbc-debuginfo-7.0.7-50.44.1
php7-opcache-7.0.7-50.44.1
php7-opcache-debuginfo-7.0.7-50.44.1
php7-openssl-7.0.7-50.44.1
php7-openssl-debuginfo-7.0.7-50.44.1
php7-pcntl-7.0.7-50.44.1
php7-pcntl-debuginfo-7.0.7-50.44.1
php7-pdo-7.0.7-50.44.1
php7-pdo-debuginfo-7.0.7-50.44.1
php7-pgsql-7.0.7-50.44.1
php7-pgsql-debuginfo-7.0.7-50.44.1
php7-phar-7.0.7-50.44.1
php7-phar-debuginfo-7.0.7-50.44.1
php7-posix-7.0.7-50.44.1
php7-posix-debuginfo-7.0.7-50.44.1
php7-pspell-7.0.7-50.44.1
php7-pspell-debuginfo-7.0.7-50.44.1
php7-shmop-7.0.7-50.44.1
php7-shmop-debuginfo-7.0.7-50.44.1
php7-snmp-7.0.7-50.44.1
php7-snmp-debuginfo-7.0.7-50.44.1
php7-soap-7.0.7-50.44.1
php7-soap-debuginfo-7.0.7-50.44.1
php7-sockets-7.0.7-50.44.1
php7-sockets-debuginfo-7.0.7-50.44.1
php7-sqlite-7.0.7-50.44.1
php7-sqlite-debuginfo-7.0.7-50.44.1
php7-sysvmsg-7.0.7-50.44.1
php7-sysvmsg-debuginfo-7.0.7-50.44.1
php7-sysvsem-7.0.7-50.44.1
php7-sysvsem-debuginfo-7.0.7-50.44.1
php7-sysvshm-7.0.7-50.44.1
php7-sysvshm-debuginfo-7.0.7-50.44.1
php7-tokenizer-7.0.7-50.44.1
php7-tokenizer-debuginfo-7.0.7-50.44.1
php7-wddx-7.0.7-50.44.1
php7-wddx-debuginfo-7.0.7-50.44.1
php7-xmlreader-7.0.7-50.44.1
php7-xmlreader-debuginfo-7.0.7-50.44.1
php7-xmlrpc-7.0.7-50.44.1
php7-xmlrpc-debuginfo-7.0.7-50.44.1
php7-xmlwriter-7.0.7-50.44.1
php7-xmlwriter-debuginfo-7.0.7-50.44.1
php7-xsl-7.0.7-50.44.1
php7-xsl-debuginfo-7.0.7-50.44.1
php7-zip-7.0.7-50.44.1
php7-zip-debuginfo-7.0.7-50.44.1
php7-zlib-7.0.7-50.44.1
php7-zlib-debuginfo-7.0.7-50.44.1

- SUSE Linux Enterprise Module for Web Scripting 12 (noarch):

php7-pear-7.0.7-50.44.1
php7-pear-Archive_Tar-7.0.7-50.44.1


References:

https://www.suse.com/security/cve/CVE-2017-9120.html
https://www.suse.com/security/cve/CVE-2018-14851.html
https://bugzilla.suse.com/1103659
https://bugzilla.suse.com/1103661

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung