Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in webkit2gtk3
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in webkit2gtk3
ID: openSUSE-SU-2018:2781-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.0
Datum: Sa, 22. September 2018, 10:47
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4272
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4267
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4262
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4270
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4271
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4263
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4264
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4261
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4284
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4266
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4278
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4265
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-4273
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-12911
Applikationen: webkit2gtk3

Originalnachricht

   openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2781-1
Rating: moderate
References: #1101999 #1104169
Cross-References: CVE-2018-12911 CVE-2018-4261 CVE-2018-4262
CVE-2018-4263 CVE-2018-4264 CVE-2018-4265
CVE-2018-4266 CVE-2018-4267 CVE-2018-4270
CVE-2018-4271 CVE-2018-4272 CVE-2018-4273
CVE-2018-4278 CVE-2018-4284
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 14 vulnerabilities is now available.

Description:

This update for webkit2gtk3 to version 2.20.5 fixes the following issues:

Security issue fixed:

- CVE-2018-12911: Fix off-by-one in xdg_mime_get_simple_globs
(bsc#1101999).
- CVE-2018-4261, CVE-2018-4262, CVE-2018-4263, CVE-2018-4264,
CVE-2018-4265, CVE-2018-4267, CVE-2018-4272, CVE-2018-4284: Processing
maliciously crafted web content may lead to arbitrary code execution. A
memory corruption issue was addressed with improved memory handling.
- CVE-2018-4266: A malicious website may be able to cause a denial of
service. A race condition was addressed with additional validation.
- CVE-2018-4270, CVE-2018-4271, CVE-2018-4273: Processing maliciously
crafted web content may lead to an unexpected application crash. A
memory corruption issue was addressed with improved input validation.
- CVE-2018-4278: A malicious website may exfiltrate audio data
cross-origin. Sound fetched through audio elements may be exfiltrated
cross-origin. This issue was addressed with improved audio taint
tracking.

Other bugs fixed:

- Fix rendering artifacts in some web sites due to a bug introduced in
2.20.4.
- Fix a crash when leaving accelerated compositing mode.
- Fix non-deterministic build failure due to missing
JavaScriptCore/JSContextRef.h.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1025=1



Package List:

- openSUSE Leap 15.0 (i586 x86_64):

libjavascriptcoregtk-4_0-18-2.20.5-lp150.2.6.1
libjavascriptcoregtk-4_0-18-debuginfo-2.20.5-lp150.2.6.1
libwebkit2gtk-4_0-37-2.20.5-lp150.2.6.1
libwebkit2gtk-4_0-37-debuginfo-2.20.5-lp150.2.6.1
typelib-1_0-JavaScriptCore-4_0-2.20.5-lp150.2.6.1
typelib-1_0-WebKit2-4_0-2.20.5-lp150.2.6.1
typelib-1_0-WebKit2WebExtension-4_0-2.20.5-lp150.2.6.1
webkit-jsc-4-2.20.5-lp150.2.6.1
webkit-jsc-4-debuginfo-2.20.5-lp150.2.6.1
webkit2gtk-4_0-injected-bundles-2.20.5-lp150.2.6.1
webkit2gtk-4_0-injected-bundles-debuginfo-2.20.5-lp150.2.6.1
webkit2gtk3-debugsource-2.20.5-lp150.2.6.1
webkit2gtk3-devel-2.20.5-lp150.2.6.1
webkit2gtk3-plugin-process-gtk2-2.20.5-lp150.2.6.1
webkit2gtk3-plugin-process-gtk2-debuginfo-2.20.5-lp150.2.6.1

- openSUSE Leap 15.0 (x86_64):

libjavascriptcoregtk-4_0-18-32bit-2.20.5-lp150.2.6.1
libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.20.5-lp150.2.6.1
libwebkit2gtk-4_0-37-32bit-2.20.5-lp150.2.6.1
libwebkit2gtk-4_0-37-32bit-debuginfo-2.20.5-lp150.2.6.1

- openSUSE Leap 15.0 (noarch):

libwebkit2gtk3-lang-2.20.5-lp150.2.6.1


References:

https://www.suse.com/security/cve/CVE-2018-12911.html
https://www.suse.com/security/cve/CVE-2018-4261.html
https://www.suse.com/security/cve/CVE-2018-4262.html
https://www.suse.com/security/cve/CVE-2018-4263.html
https://www.suse.com/security/cve/CVE-2018-4264.html
https://www.suse.com/security/cve/CVE-2018-4265.html
https://www.suse.com/security/cve/CVE-2018-4266.html
https://www.suse.com/security/cve/CVE-2018-4267.html
https://www.suse.com/security/cve/CVE-2018-4270.html
https://www.suse.com/security/cve/CVE-2018-4271.html
https://www.suse.com/security/cve/CVE-2018-4272.html
https://www.suse.com/security/cve/CVE-2018-4273.html
https://www.suse.com/security/cve/CVE-2018-4278.html
https://www.suse.com/security/cve/CVE-2018-4284.html
https://bugzilla.suse.com/1101999
https://bugzilla.suse.com/1104169

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung