Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in qpdf
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in qpdf
ID: SUSE-SU-2018:3066-2
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12-SP2-BCL
Datum: Do, 18. Oktober 2018, 23:46
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11626
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9210
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11627
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12595
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11625
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-11624
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9208
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9209
Applikationen: qpdf

Originalnachricht

   SUSE Security Update: Security update for qpdf
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:3066-2
Rating: moderate
References: #1040311 #1040312 #1040313 #1050577 #1050578
#1050579 #1050581 #1055960
Cross-References: CVE-2017-11624 CVE-2017-11625 CVE-2017-11626
CVE-2017-11627 CVE-2017-12595 CVE-2017-9208
CVE-2017-9209 CVE-2017-9210
Affected Products:
SUSE Linux Enterprise Server 12-SP2-BCL
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available.

Description:



This update for qpdf fixes the following issues:

qpdf was updated to 7.1.1.

Security issues fixed:

- CVE-2017-11627: A stack-consumption vulnerability which allows attackers
to cause DoS (bsc#1050577).
- CVE-2017-11625: A stack-consumption vulnerability which allows attackers
to cause DoS (bsc#1050579).
- CVE-2017-11626: A stack-consumption vulnerability which allows attackers
to cause DoS (bsc#1050578).
- CVE-2017-11624: A stack-consumption vulnerability which allows attackers
to cause DoS (bsc#1050581).
- CVE-2017-12595: Stack overflow when processing deeply nested arrays and
dictionaries (bsc#1055960).
- CVE-2017-9209: Remote attackers can cause a denial of service (infinite
recursion and stack consumption) via a crafted PDF document
(bsc#1040312).
- CVE-2017-9210: Remote attackers can cause a denial of service (infinite
recursion and stack consumption) via a crafted PDF document
(bsc#1040313).
- CVE-2017-9208: Remote attackers can cause a denial of service (infinite
recursion and stack consumption) via a crafted PDF document
(bsc#1040311).

* Check release notes for detailed bug fixes.
* http://qpdf.sourceforge.net/files/qpdf-manual.html#ref.release-notes


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 12-SP2-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-2169=1



Package List:

- SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

cups-filters-1.0.58-15.2.1
cups-filters-cups-browsed-1.0.58-15.2.1
cups-filters-cups-browsed-debuginfo-1.0.58-15.2.1
cups-filters-debuginfo-1.0.58-15.2.1
cups-filters-debugsource-1.0.58-15.2.1
cups-filters-foomatic-rip-1.0.58-15.2.1
cups-filters-foomatic-rip-debuginfo-1.0.58-15.2.1
cups-filters-ghostscript-1.0.58-15.2.1
cups-filters-ghostscript-debuginfo-1.0.58-15.2.1
libqpdf18-7.1.1-3.3.4
libqpdf18-debuginfo-7.1.1-3.3.4
qpdf-7.1.1-3.3.4
qpdf-debuginfo-7.1.1-3.3.4
qpdf-debugsource-7.1.1-3.3.4


References:

https://www.suse.com/security/cve/CVE-2017-11624.html
https://www.suse.com/security/cve/CVE-2017-11625.html
https://www.suse.com/security/cve/CVE-2017-11626.html
https://www.suse.com/security/cve/CVE-2017-11627.html
https://www.suse.com/security/cve/CVE-2017-12595.html
https://www.suse.com/security/cve/CVE-2017-9208.html
https://www.suse.com/security/cve/CVE-2017-9209.html
https://www.suse.com/security/cve/CVE-2017-9210.html
https://bugzilla.suse.com/1040311
https://bugzilla.suse.com/1040312
https://bugzilla.suse.com/1040313
https://bugzilla.suse.com/1050577
https://bugzilla.suse.com/1050578
https://bugzilla.suse.com/1050579
https://bugzilla.suse.com/1050581
https://bugzilla.suse.com/1055960

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung