Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in go
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in go
ID: openSUSE-SU-2018:4302-1
Distribution: SUSE
Plattformen: SUSE openSUSE Backports SLE-15
Datum: So, 30. Dezember 2018, 12:09
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-7187
Applikationen: Go

Originalnachricht

   openSUSE Security Update: Security update for go
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4302-1
Rating: important
References: #1081495 #1119634 #1119706
Cross-References: CVE-2018-7187
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for go fixes the following issues:

- golang: arbitrary command execution via VCS path (bsc#1081495,
CVE-2018-7187)
- Make profile.d/go.sh no longer set GOROOT=, in order to make switching
between versions no longer break. This ends up removing the need for
go.sh entirely (because GOPATH is also set automatically) (boo#1119634)
- Fix a regression that broke go get for import path patterns containing
"..." (bsc#1119706)

Additionally, the package go1.10 has been added.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2018-1625=1



Package List:

- openSUSE Backports SLE-15 (aarch64 ppc64le s390x x86_64):

go-1.10.4-bp150.2.3.1
go-doc-1.10.4-bp150.2.3.1
go1.10-1.10.7-bp150.2.1
go1.10-doc-1.10.7-bp150.2.1

- openSUSE Backports SLE-15 (x86_64):

go-race-1.10.4-bp150.2.3.1
go1.10-race-1.10.7-bp150.2.1

- openSUSE Backports SLE-15 (noarch):

golang-packaging-15.0.11-bp150.3.3.1


References:

https://www.suse.com/security/cve/CVE-2018-7187.html
https://bugzilla.suse.com/1081495
https://bugzilla.suse.com/1119634
https://bugzilla.suse.com/1119706

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Frohe Ostern
Neue Nachrichten
Werbung