Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in osc
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in osc
ID: openSUSE-SU-2019:1844-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mo, 12. August 2019, 23:03
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3685
Applikationen: osc

Originalnachricht

   openSUSE Security Update: Security update for osc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:1844-1
Rating: important
References: #1129889 #1138977 #1140697 #1142518 #1142662
#1144211
Cross-References: CVE-2019-3685
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves one vulnerability and has 5 fixes is
now available.

Description:

This update for osc to version 0.165.4 fixes the following issues:

Security issue fixed:

- CVE-2019-3685: Fixed broken TLS certificate handling allowing for a
Man-in-the-middle attack (bsc#1142518).

Non-security issues fixed:

- support different token operations (runservice, release and rebuild)
(requires OBS 2.10)
- fix osc token decode error
- offline build mode is now really offline and does not try to download
the buildconfig
- osc build -define now works with python3
- fixes an issue where the error message on osc meta -e was not parsed
correctly
- osc maintainer -s now works with python3
- simplified and fixed osc meta -e (bsc#1138977)
- osc lbl now works with non utf8 encoding (bsc#1129889)
- add simpleimage as local build type
- allow optional fork when creating a maintenance request
- fix RPMError fallback
- fix local caching for all package formats
- fix appname for trusted cert store
- osc -h does not break anymore when using plugins
- switch to difflib.diff_bytes and sys.stdout.buffer.write for diffing.
This will fix all decoding issues with osc diff, osc ci and osc rq -d
- fix osc ls -lb handling empty size and mtime
- removed decoding on osc api command.

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-1844=1



Package List:

- openSUSE Leap 15.1 (noarch):

osc-0.165.4-lp151.2.6.1


References:

https://www.suse.com/security/cve/CVE-2019-3685.html
https://bugzilla.suse.com/1129889
https://bugzilla.suse.com/1138977
https://bugzilla.suse.com/1140697
https://bugzilla.suse.com/1142518
https://bugzilla.suse.com/1142662
https://bugzilla.suse.com/1144211

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung